A Bug's Life

A Bug's Life

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
输入
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 10000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
输出
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
样例输入
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
样例输出
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

思路:

加权并查集, 和食物链一样(关系数不同), 在考虑关系时, 参考向量关系运算。

#include <stdio.h>

struct Node
{
	int root;                    //根节点(最上层节点,不一定是父节点)
	int relation;                //与根节点关系,方向是root指向它
}bug[10001];

int findroot(int x)              //寻找x的根节点, 并在回溯的路上更新relation
{
	if(x == bug[x].root)
	{
		return x;
	}
	int temp = bug[x].root;
	bug[x].root = findroot(temp);
	bug[x].relation = (bug[x].relation + bug[temp].relation)%2; //此处更新relation
	return bug[x].root;
}

int main() {
	int n, m, i, a, b, t, flag, cnt, fa, fb;
	scanf("%d", &t);
	cnt = 0;                              //计数
	while(t--)
	{
		scanf("%d%d", &n, &m);
		for(i = 1; i < n; i++)             //初始化bug数组
		{
			bug[i].root = i;
			bug[i].relation = 0;
		}
		flag = 1;
		printf("Scenario #%d:\n", ++cnt);
		for(i = 0; i < m; i++)
		{
			scanf("%d%d", &a, &b);
			if(!flag)                      //剪枝
			{
				continue;
			}
			fa = findroot(a);
			fb = findroot(b);
			if(fa != fb)
			{
				bug[fa].root = fb;          //将两个分支合并(出现了新节点)
				bug[fa].relation = (bug[b].relation + 1 + 2 - bug[a].relation) % 2;  //更新根节点之间的关系(下面子节点会在findroot更新)
			}
			else
			{
				if(bug[a].relation == bug[b].relation)            //若相同就不是异性了。。。
				{
					flag = 0;
				}
			}
		}
		if(flag)                                  //打印结果
		{
			printf("No suspicious bugs found!\n");
		}
		else
		{
			printf("Suspicious bugs found!\n");
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值