Square Country

Square Country

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
There live square people in a square country. Everything in this country is square also. Thus, the Square Parliament has passed a law about a land. According to the law each citizen of the country has a right to buy land. A land is sold in squares, surely. Moreover, a length of a square side must be a positive integer amount of meters. Buying a square of land with a side  a one pays  a 2 quadrics (a local currency) and gets a square certificate of a landowner.
One citizen of the country has decided to invest all of his  N quadrics into the land. He can, surely, do it, buying square pieces 1 × 1 meters. At the same time the citizen has requested to minimize an amount of pieces he buys: "It will be easier for me to pay taxes," — he has said. He has bought the land successfully.
Your task is to find out a number of certificates he has gotten.
输入
There are hundreds of test cases,The line contains a positive integer N ≤ 60 000 , that is a number of quadrics that the citizen has invested.
输出
The line contains a number of certificates that he has gotten.
样例输入
19
60000
0
样例输出
3

3

思路:

动态规划, 类似于背包问题。

#include <stdio.h>
#include <string.h>
#include <math.h>

int dp[60001];

int main()
{
    int i, j, n, tmin;
    memset(dp, 0, sizeof(dp));
    for(i = 1; i <= 60000; i++)
    {
        tmin = 0xfffffff;
        for(j = 1; j <= (int)sqrt((double)60000) && j*j <= i; j++)
        {
            if(dp[i-j*j]+1 < tmin)
            {
                tmin = dp[i-j*j]+1;
            }
        }
        dp[i] = tmin;
    }
    while(scanf("%d", &n) && n != 0)
    {
        printf("%d\n", dp[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值