poj_Crosses and Crosses_3537

Crosses and Crosses
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 2459 Accepted: 915
Case Time Limit: 2000MS

Description

The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.

You are given n. Find out who wins if both players play optimally.

Input

Input file contains one integer number n (3 ≤ n ≤ 2000).

Output

Output ‘1’ if the first player wins, or ‘2’ if the second player does.

Sample Input

 
 
#13
#26

Sample Output

 
 
#11
#22
 
考虑到如果画上一个X,就会有临近区域不能画X,也就是下一个人能画X的区域就变了,那么问题可以转换为谁不能画X谁就输了。

#include <iostream>
#include <cstring>
#include <cstdio>
#define N 2010
using namespace std;

int g[N];
int n;

int sg(int num)
{
    //if(num <= 0)
     //   return 0;
    if(g[num] != -1)
        return g[num];
    bool visit[N * 2];
    memset(visit, 0, sizeof(visit));
    visit[sg(num - 3)] = 1;
    visit[sg(num - 4)] = 1;
    for (int i = 0; i <= (num - 5) / 2; i++)
    {
        int t1 = sg(i);
        int t2 = sg(num - 5 - i);
        visit[t1 ^ t2] = 1;
    }
    g[num] = 0;
    while (visit[g[num]])
        g[num] ++;
    return g[num];
}

int main()
{
    memset(g, -1, sizeof(g));
    g[0] = 0;
    g[1] = 1;
    g[2] = 1;
    g[3] = 1;
    g[4] = 2;
    g[5] = 2;
    while (scanf("%d", &n) != EOF)
    {
        if (sg(n) == 0)
            printf("2\n");
        else 
            printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值