hdu 5534 Partial Tree

Partial Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 366    Accepted Submission(s): 204


Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has  n  nodes but lacks of  n1  edges. You want to complete this tree by adding  n1  edges. There must be exactly one path between any two nodes after adding. As you know, there are  nn2  ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is  f(d) , where  f  is a predefined function and  d  is the degree of this node. What's the maximum coolness of the completed tree?
 

Input
The first line contains an integer  T  indicating the total number of test cases.
Each test case starts with an integer  n  in one line,
then one line with  n1  integers  f(1),f(2),,f(n1) .

1T2015
2n2015
0f(i)10000
There are at most  10  test cases with  n>100 .
 

Output
For each test case, please output the maximum coolness of the completed tree in one line.
 

Sample Input
  
  
2 3 2 1 4 5 1 4
 

Sample Output
  
  
5 19
 

Source
 


 首先我们要知道prufer sequence这个东西,那么我们就知道可以用n-2的任意序列来表示n个节点的树,同时我们可以知道序列里决定节点度数的是这个节点在数列里出现了多少次,那么,我们对序列排序之后,结构虽然改变,节点度数不变,于是可以用f[i][j]表示前i个点,最后那个点出现了j次产生的值。f[i][j]=f[i-1][j-1]+v[j+1]-v[j];
f[i][1]=max(f[i-1][j])+v[2]-v[1];f[0][0]=n*v[1];
#include<bits/stdc++.h>
using namespace std;
const int maxn=2100;
const int inf=1000000000;
int v[maxn],n,f[maxn][maxn];
void work(){
    scanf("%d",&n);
    for(int i=1;i<n;i++)scanf("%d",v+i);
    for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)f[i][j]=-inf;
    f[0][0]=n*v[1];
    for(int i=1;i<=n-2;i++){
        int tmp=-inf;
        for(int j=1;j<=i;j++){
            f[i][j]=f[i-1][j-1]+v[j+1]-v[j];
            tmp=max(tmp,f[i-1][j-1]);
        }
        f[i][1]=tmp+v[2]-v[1];
    }
    int ans=f[n-2][0];
    for(int i=1;i<=n;i++)ans=max(ans,f[n-2][i]);
    printf("%d\n",ans);
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--)work();
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值