radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
第一种方案:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#define M 10000

typedef struct data
{
	double left, right;
}Data;

int com(const void *p, const void *q)
{
	return ((Data *)p)->left > ((Data *)q)->left ? 1 : -1;
}

int main()
{
	double n, m;
	int num = 0, count = 0;
	int i = 0, result = 0, mark = 0;	
	Data data[M];
	double a[M][2], r = 0, me;

	for(;;)
	{
		num = 0;
		mark = 0;	
		memset(a, -1, 2 * M);	
		scanf("%lf %lf", &n, &m);
		getchar();

		if(n == 0 && m == 0)
			return 0;
		for(i = 0; i < n; i++)
		{
			scanf("%lf %lf", &a[i][0], &a[i][1]);
			getchar();
			if(a[i][1] > m)//如果岛屿的位置大于雷达的辐射半径,说明不可能有解决方案
				mark = 1;				
		}	
		for(i = 0; i < n; i++)
		{
			r = m * m - a[i][1] * a[i][1];
			data[i].left = a[i][0] - sqrt(r);
			data[i].right = a[i][0] + sqrt(r);
		}
		qsort(data, n, sizeof(Data), com);//按雷达辐射范围的左边坐标从左到右排序

		me = data[0].right;//将第一个雷达放到第一个岛屿的右坐标上
		num ++;//次数加一
		for(i = 1; i < n; i++)//从第二个岛屿的范围开始遍历
		{
			if(data[i].left > me + 0.00005)//如果下一个岛屿的左坐标大于当前的雷达说明雷达要再加一个且放到下一个岛屿的右坐标,并将其标记
			{
				me = data[i].right;
				num++;
			}
			else //如果下一个岛屿的右坐标还小与当前的雷达位置,说明当前雷达辐射不到下一个岛屿,只要将当前雷达移到下一个岛屿的右坐标就可以了
			{	
				if(data[i].right < me + 0.00005)		
					me = data[i].right;
			}
		}
		if(mark == 0)
			printf("Case %d: %d\n", ++count, num);
		else
			printf("Case %d: -1\n", ++count);
	}

	return 0;
}
第二种方案:
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <time.h>
#define M 1000

typedef struct data
{
	double x, y;
}Data;

int count = 0;
double n = 0, m = 0;
int find(Data data[]);
int com(const void *p, const void *q);

int main()
{
	int i = 0, result = 0;
	Data data[M];

	for(;;)
	{		
		scanf("%lf %lf", &n, &m);
		getchar();

		if(n == 0 && m == 0)
			return 0;
		for(i = 0; i < n; i++)
		{
			scanf("%lf %lf", &data[i].x, &data[i].y);
			getchar();					
		}	
		qsort(data, n, sizeof(Data), com);//按照雷达的位置从左到右排序
		result = find(data);
		printf("Case %d: %d\n", ++count, result);
	}
	return 0;
}

int com(const void *p, const void *q)
{
	return ((Data *)p)->x - ((Data *)q)->x;
}

int find(Data data[])
{
	int i, num = 0;
	double me;
	double x[2] = {0}, r;
	
	if(m < data[0].y)
	{
		return -1;
	}
	r = m * m - data[0].y * data[0].y;
	x[1] = data[0].x + sqrt(r);
	me = x[1];
	num++;
	for(i = 1; i < n; i++)
	{
		if(m < data[i].y || data[i].y < 0)//如果岛屿的位置小于0或者大于雷达的辐射半径,则说明没有解决方案
		{
			num = -1;
			break;
		}
		r = m * m - data[i].y * data[i].y;
		x[0] = data[i].x - sqrt(r);
		x[1] = data[i].x + sqrt(r);
		if(me < x[0]) //如果当前雷达的位置小于下一个岛屿的左坐标则需要再添加一个雷达且添加位置为下一个岛屿的右坐标
		{
			me = x[1];
			num++;
		}
		else 
		{
			if(x[1] < me)//如果下一个岛屿的右坐标小于当前雷达,说明当前的雷达辐射不到下一个岛屿,则将当前雷达移到下一个岛屿的右坐标
				me = x[1];
		}
 	}
	return num;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值