BZOJ3315 [Usaco2013 Nov]Pogo-Cow

[Usaco2013 Nov]Pogo-Cow

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 17   Solved: 13
[ Submit][ Status]

Description

In an ill-conceived attempt to enhance the mobility of his prize cow Bessie, Farmer John has attached a pogo stick to each of Bessie's legs. Bessie can now hop around quickly throughout the farm, but she has not yet learned how to slow down. To help train Bessie to hop with greater control, Farmer John sets up a practice course for her along a straight one-dimensional path across his farm. At various distinct positions on the path, he places N targets on which Bessie should try to land (1 <= N <= 1000). Target i is located at position x(i), and is worth p(i) points if Bessie lands on it. Bessie starts at the location of any target of her choosing and is allowed to move in only one direction, hopping from target to target. Each hop must cover at least as much distance as the previous hop, and must land on a target. Bessie receives credit for every target she touches (including the initial target on which she starts). Please compute the maximum number of points she can obtain.

一个坐标轴有N个点,每跳到一个点会获得该点的分数,并只能朝同一个方向跳,但是每一次的跳跃的距离必须不小于前一次的跳跃距离,起始点任选,求能获得的最大分数。

Input

* Line 1: The integer N.

* Lines 2..1+N: Line i+1 contains x(i) and p(i), each an integer in the range 0..1,000,000.

Output

* Line 1: The maximum number of points Bessie can receive.

Sample Input

6
5 6
1 1
10 5
7 6
4 8
8 10

INPUT DETAILS: There are 6 targets. The first is at position x=5 and is worth 6 points, and so on.

Sample Output

25
OUTPUT DETAILS: Bessie hops from position x=4 (8 points) to position x=5 (6 points) to position x=7 (6 points) to position x=10 (5 points).

从坐标为4的点,跳到坐标为5的,再到坐标为7和,再到坐标为10的。

HINT

Source

Silver





设f[i][j]表示起点为i,第二步为j
O(n^3)还是很好想的。。。
单调队列优化一下就可以了。。。


#include<cstdlib>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1010;
struct point{
    int x, v;
}a[maxn];
bool cmp1(point a, point b){ return a.x < b.x; }
bool cmp2(point a, point b){ return a.x > b.x; }
int n, f[maxn][maxn];
void init(){
    scanf("%d", &n);
    for (int i = 1; i <= n; i ++) scanf("%d%d",&a[i].x, &a[i].v);
}
int h[maxn][2];
int ans;
void work(){
    for (int i = n; i >= 1; i --){
        f[i][i] = a[i].v;
        int tt = 1, ww = 0;
        for (int j = i + 1; j <= n; j ++){
            while (ww >= tt && f[i][j] >= h[ww][1]) ww --;
            h[++ww][0] = j, h[ww][1] = f[i][j];
        }
        for (int j = i - 1; j >= 1; j --){
            f[j][i] = a[j].v + a[i].v;
            while (ww >= tt && abs(a[h[tt][0]].x - a[i].x) < abs(a[i].x - a[j].x)) tt ++;
            if (ww >= tt) f[j][i] = max(f[j][i], a[j].v + h[tt][1]);
            ans = max(ans, f[j][i]); 
        }
    }
}
int main(){
    init();
    sort(a + 1, a + n + 1, cmp1);
    work();
    sort(a + 1, a + n + 1, cmp2);
    work();
    cout <<ans <<endl;
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值