老BOJ 06 Flip Game

10 篇文章 0 订阅
9 篇文章 0 订阅
Flip Game
Accept:132    Submit:648
Time Limit:1000MS    Memory Limit:65536KB

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

Thefirst line is a positive integer m , indicating the number of test cases . Then m test cases .Each case consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

1

bwwb

bbwb

bwwb

bwww

Sample Output

4

DFS枚举

#include<stdio.h>
#include<iostream>
using namespace std;
int chess[4][4];
int c=33;
void build()//将棋盘的颜色以标记化
{
    char c;
    int i,j;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
        {
            cin>>c;
            if(c=='w')
                chess[i][j]=0;
            else
                chess[i][j]=1;
        }
}
void turn(int x,int y)//翻转
{
    if(x>=0&&x<=3&&y>=0&&y<=3)
        chess[x][y]=!chess[x][y];
}
void flip(int s)//一个棋子变化,周围四个都要变化
{
    int i=s/4;//行
    int j=s%4;//列
    turn(i,j);
    turn(i+1,j);
    turn(i,j+1);
    turn(i-1,j);
    turn(i,j-1);
}
int complete()//判断棋盘是否变成同一的颜色
{
    int i,j,s1=0;
    for(i=0; i<4; i++)
        for(j=0; j<4; j++)
            s1+=chess[i][j];
    if(s1%16)
        return 0;
    else
        return 1;
}
void dfs(int s,int b)//进行深搜.s代表当前的方格,b代表翻转的方格数
{
    if(complete())//如果是同一颜色
    {
        if(c>b)c=b;
        return;
    }
    if(s>=16)//如果遍历完
        return;
    dfs(s+1,b);//对每一个棋子都开始进行翻转
    flip(s);//做出翻转自己的第一步
    dfs(s+1,b+1);//再对翻转之后的局面每一个进行再一次的翻转
    flip(s);//again
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        c=33;
        build();//将棋盘的颜色以标记化
        dfs(0,0);
        if(c==33)//由于翻转次数最多为4*4*2=32次
            printf("Impossible\n");
        else
            printf("%d\n",c);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值