AOJ 12 box of bricks

 problem:

         

Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. 

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 


Output
For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.

Sample Input
Original Transformed
6
5 2 4 1 7 5
0

Sample Output
Original Transformed
Set #1
The minimum number of moves is 5.

 欸。。题目很简单,干嘛要整个英文呢~害的我好半天都是“presentation error” 原来题目有要求要每个输出之后有一个空行。。
没有什么新鲜的地方,唯一值得提的就是vector容器的clean()操作,就是把这个容器全部某掉,在这个多组数据输出题目中真的很必要,当然这个操作也体现了容器的优势,要是用数组存储数据的话又要用一个循环才能清除了~想到英国人的一句谚语‘不要再重复发明轮子’
   C++ 的STL真的很方便,这句话用来形容STL 真的再合适不过了~。代码直接贴上:
      
//AOJ 12 box of bricks
#include<iostream>
#include<vector>
using namespace std;
int main()
{
  int n,temp,sum,avg,steps,num;
  cin>>n;
  num=0;
  vector<int> vec;
 while(n!=0){
	 num++;
	 sum=0;
	 steps=0;
	 for(int i=1;i<=n;i++){ 
		 cin>>temp;
		 vec.push_back(temp);
		 sum+=temp;
	 }
	 avg=sum/n;
	 for(vector<int>::iterator iter=vec.begin();iter!=vec.end();iter++)
		 if(*iter<avg) steps+=avg-*iter;
	 cout<<"Set #"<<num<<endl;
	 cout<<"The minimum number of moves is "<<steps<<"."<<endl;
	 cout<<endl;
	 cin>>n;
	 vec.clear();
 }  
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值