poj 1125

Stockbroker Grapevine
Time Limit: 1000MS		Memory Limit: 10000K
Total Submissions: 24965		Accepted: 13758
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output

3 2
3 10

题目大意:输入一个有向图,n个顶点表示n个人,每个人可以向相连的人散播消息,相连的有向边表示需要的时间。而且在一定时间内,消息是“同时”传播到所有相邻的人那里。求消息从哪个人开始传播,所需要的时间最短,输出此人编号和最短时间。当图不连通即无论怎样都有人得不到消息时,输出“disjoint”

思路:floyd算法求出每个人到其他相邻各人的最短时间,对每个人求出到其他各人最短时间里的最长时间,因为只有这样,才能保证从此人出发的时候把消息传达到了所有人那里。找这n个人里最长时间最短的那个,就是答案。

 

代码:

#include<stdio.h>
#include<string.h>
int D[101][101];
int n, max[101], min = 65535; 

void init_map()
{
	int i,j;
	for(i = 1; i <= n; i++)
	{
		for(j = 1; j <= n; j++)
		{
			if(i == j)
				D[i][j] = 0;
			else
				
				D[i][j] = 65535;
		}
	}
}


void floyed()
{
	int v,w, k;
	for(v = 1; v <= n; v++)
	{
		for(w = 1; w <= n; w++)
		{
			for(k = 1; k <= n; k++)
			{
				if(D[w][k] > D[w][v] + D[v][k])
				{
					D[w][k] = D[w][v] + D[v][k];
				}
			}
		}
	}

}
int main()
{
	int i,j, v, num,A,B, dnum, flag = 0;
	while(scanf("%d", &n), n)
	{
		min = 65535;
		memset(max, 0, sizeof(max));
		init_map();
		for(i = 1; i <= n; i++)
		{
			scanf("%d", &num);
			for(j = 0; j < num; j++)
			{
				scanf("%d %d", &A, &B);
				D[i][A] = B;
			}
		}
		floyed();
		flag = 0;
		for(i = 1; i <= n; i++)
		{
			dnum = 0;
			for(j = 1; j <= n; j++)
			{
				if(D[i][j] != 0 && D[i][j] != 65535)
				{
					dnum++;
				}
				if(D[i][j] > max[i] && D[i][j] != 65535)
				{
					max[i] = D[i][j];
				}
			}
			if(min > max[i] && dnum == n - 1)
			{
				flag = 1;
				min = max[i];
				v = i;
			}
		}
		if(flag == 1)
		{
			printf("%d %d\n", v, min);
		}
		else
		{
			printf("disjoint\n");
		}
	}
	return 0;

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值