poj 3041(最大匹配问题)

http://poj.org/problem?id=3041
Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14476 Accepted: 7880

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

题目大意是导弹可以消灭直线上的障碍物,给出障碍物的位置,问最少需要多少导弹,把矩阵中的行放一边,列放另一边,按二分图做,就不是很难了,这一类的题目主要就是主函数那里有点不一样,其他套着模板来。

模板题

AC代码:

#include <stdio.h>
#include <string.h>
#define MAXN 510

int N,K,ans;
bool map[MAXN][MAXN];
int match[MAXN];
bool vis[MAXN];

bool find(int u)
{
	int i;
	for ( i=1; i<=N; i++)
	{
		if (map[u][i] && !vis[i] )
		{
			vis[i] = true;
			if ( match[i] == -1 || find(match[i]) )
			{
				match[i] = u;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int i,x,y;
	ans = 0;
	scanf("%d%d",&N,&K);
	memset(map,0,sizeof(map));
	memset(match,-1,sizeof(match));
	for (i=0; i<K; i++)
	{
		scanf("%d%d",&x,&y);
		map[x][y] = 1;
	}
	for (i=1; i<=N; i++)
	{
		memset(vis,0,sizeof(vis));
		if (find(i))
			ans++;
	}
	printf("%d\n",ans);
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值