循环小数

循环小数
Time Limit : 3000/1000ms (Java/Other) Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 15 Accepted Submission(s) : 4
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Given a floating point number X, the form is X=0.a1a2...an(b1b2...bm)(1<=n,m<=8). (b1b2...bm) indicates the repetend. For example, 0.5=0.50=0.5(0)=0.5(00)=1/2,0.3(3)=0.333(33)=1/3.
Please change the floating point number X into a fraction A/B(gcd(A,B)=1).

Input

Input may contain several test cases. The first line is a positive integer, T(T<=10) indicating the number of test cases below.
For each test case, the first line contains two integers n,m(1<=n,m<=8).
The following line contains n numbers a1a2...an.
The following line contains m numbers b1b2...bm.

Output

For each case, output the number A and B(0<A,B) on a single line.

Sample Input

2
2 2
50
00
4 2
3333
33

Sample Output

1 2
1 3

Author

//无限循环小数化为分数

参考这里: http://wenku.baidu.com/view/561773c62cc58bd63186bd87.html

#include<cstdio>

__int64 solve(__int64 a,__int64 b)
{
    return b==0?a:solve(b,a%b);
}

int main()
{
    int t,n,m;
    __int64 a,b,z,x,y;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%I64d%I64d",&n,&m,&a,&b);
        x=a;
        y=0;
        while(m--)
        {
            x*=10;
            y=y*10+9;
        }
        x=x+b-a;
        while(n--)
        {
            y*=10;
        }
        z=solve(x,y);
        //printf("%I64d %I64d\n",x,y);
        printf("%I64d %I64d\n",x/z,y/z);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值