UVA 1347 Tour DP


DP

dp[i][j] 前i个点已经全部走过,落后的那个人在j号点

往i+1号点转移 既 dp[i+1][i]   or   dp[i+1][j]


Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visiting beautiful places. To save money, John must determine the shortest closed tour that connects his destinations. Each destination is represented by a point in the plane pi = < xiyi > . John uses the following strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmost point, and then he goes strictly right back to the starting point. It is known that the points have distinct x -coordinates.

Write a program that, given a set of n points in the plane, computes the shortest closed tour that connects the points according to John's strategy.

Input 

The program input is from a text file. Each data set in the file stands for a particular set of points. For each set of points the data set contains the number of points, and the point coordinates in ascending order of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output 

For each set of data, your program should print the result to the standard output from the beginning of a line. The tour length, a floating-point number with two fractional digits, represents the result.


Note: An input/output sample is in the table below. Here there are two data sets. The first one contains 3 points specified by their x and y coordinates. The second point, for example, has the x coordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the first data set in the given example).

Sample Input 

3 
1 1
2 3
3 1
4 
1 1 
2 3
3 1
4 2

Sample Output 

6.47
7.89

Source

Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Rare Topics :: Rare Problems ::  Bitonic TSP
Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 9. Dynamic Programming ::  Examples
Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 1. Algorithm Design :: Dynamic Programming ::  Exercises: Intermediate

 Status


/* ***********************************************
Author        :CKboss
Created Time  :2015年02月07日 星期六 22时23分20秒
File Name     :UVA1347.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=1111;

int n;
struct point
{
	double x,y;
}pt[maxn];

double dist(int a,int b)
{
	double dx=fabs(pt[a].x-pt[b].x);
	double dy=fabs(pt[a].y-pt[b].y);
	return sqrt(dx*dx+dy*dy);
}

double dp[maxn][maxn];

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++) scanf("%lf%lf",&pt[i].x,&pt[i].y);

		for(int i=0;i<maxn;i++)
			for(int j=0;j<maxn;j++)
				dp[i][j]=(1LL<<60);

		dp[0][0]=0; dp[1][0]=dist(1,0);
		for(int i=1;i<n;i++)
		{
			for(int j=0;j<i;j++)
			{
				dp[i+1][i]=min(dp[i+1][i],dp[i][j]+dist(j,i+1));
				dp[i+1][j]=min(dp[i+1][j],dp[i][j]+dist(i,i+1));
			}
		}

		double ans=1LL<<60;
		for(int i=0;i<n;i++)
			ans=min(ans,dp[n-1][i]+dist(i,n-1));

		printf("%.2lf\n",ans);
	}
    
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值