UVA1347 Tour

John Doe, a skilled pilot, enjoys traveling. While on vacation, he rents a small plane and starts visitingbeautiful places. To save money, John must determine the shortest closed tour that connects hisdestinations. Each destination is represented by a point in the plane pi =< xi, yi >. John uses thefollowing strategy: he starts from the leftmost point, then he goes strictly left to right to the rightmostpoint, and then he goes strictly right back to the starting point. It is known that the points havedistinct x-coordinates.Write a program that, given a set of n points in the plane, computes the shortest closed tour thatconnects the points according to John’s strategy.

Input

The program input is from a text file. Each data set in the file stands for a particular set of points. Foreach set of points the data set contains the number of points, and the point coordinates in ascendingorder of the x coordinate. White spaces can occur freely in input. The input data are correct.

Output

For each set of data, your program should print the result to the standard output from the beginningof a line. The tour length, a floating-point number with two fractional digits, represents the result.Note: An input/output sample is in the table below. Here there are two data sets. The first onecontains 3 points specified by their x and y coordinates. The second point, for example, has the xcoordinate 2, and the y coordinate 3. The result for each data set is the tour length, (6.47 for the firstdata set in the given example)

Sample Input

3

1 1

2 3

3 1

4

1 1

2 3

3 1

4 2

Sample Output

6.47

7.89

代码:

#include<cstdio>
#include<cmath>
#include<algorithm>
#define maxn 55
using namespace std;
int n;
double x[maxn],y[maxn];
double jl[maxn][maxn],f[maxn][maxn];
int main()
{
	while(scanf("%d", &n)==1) 
    {
    	for(int i=1;i<=n;i++) scanf("%lf%lf",&x[i],&y[i]);
    	for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
            jl[i][j]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
    	for(int i=n-1;i>=2;i--)
      	  for(int j=1;j<i;j++) 
		  {
        	if(i==n-1) f[i][j]=jl[i][n]+jl[j][n]; 
        	  else f[i][j]=min(jl[i][i+1]+f[i+1][j],jl[j][i+1]+f[i+1][i]);
      	  }
    	printf("%.2lf\n",jl[1][2]+f[2][1]);
  }
  return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值