HDOJ 4135 Co-prime 容斥原理


求得n的因数后,简单容斥

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1798    Accepted Submission(s): 685


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年03月27日 星期五 17时52分24秒
File Name     :HDOJ4135.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

LL A,B,N;
vector<LL> pr;

void getPr()
{
	LL TN=N,now=2;
	pr.clear();
	
	while(TN!=1)
	{
		if(TN%now==0)
		{
			pr.push_back(now);
			while(TN%now==0) TN/=now;
		}
		now++;
		if(now*now>TN) break;
	}
	if(TN!=1) pr.push_back(TN);
}

LL RET,RET1,RET2;

void dfs(int x,LL n,int mark)
{
	for(int i=x,sz=pr.size();i<sz;i++)
	{
		RET+=mark*(n/pr[i]);
		dfs(i+1,n/pr[i],-mark);
	}
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int T_T,cas=1;
	cin>>T_T;
	while(T_T--)
	{
		cin>>A>>B>>N;
		getPr();
		A--; RET=A; dfs(0,A,-1); RET1=RET;
		RET=B; dfs(0,B,-1); RET2=RET;
		cout<<"Case #"<<cas++<<": "<<RET2-RET1<<endl;
	}
    
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值