HDOJ 5424 Rikka with Graph II 暴力dfs


哈密顿路径本来是NPC的问题,不过这题可以特判后直接暴力dfs

Rikka with Graph II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1066    Accepted Submission(s): 271


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with  n  vertices and  n  edges. Now he wants you to tell him if there exist a Hamiltonian path.

It is too difficult for Rikka. Can you help her?
 

Input
There are no more than 100 testcases. 

For each testcase, the first line contains a number  n(1n1000) .

Then  n  lines follow. Each line contains two numbers  u,v(1u,vn)  , which means there is an edge between  u  and  v .
 

Output
For each testcase, if there exist a Hamiltonian path print "YES" , otherwise print "NO".
 

Sample Input
  
  
4 1 1 1 2 2 3 2 4 3 1 2 2 3 3 1
 

Sample Output
  
  
NO YES Hint For the second testcase, One of the path is 1->2->3 If you doesn't know what is Hamiltonian path, click here (https://en.wikipedia.org/wiki/Hamiltonian_path).
 

Source
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年09月03日 星期四 08时33分46秒
File Name     :HDOJ5424.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=1100;

int fa[maxn];

int Find(int x)
{
	return (x==fa[x])?x:fa[x]=Find(fa[x]);
}

void Union(int u,int v)
{
	u=Find(u); v=Find(v);
	if(u==v) return ;
	fa[u]=v;
}

int n,du[maxn];
bool vis[maxn];
vector<int> G[maxn];
bool flag;

void dfs(int u,int c)
{
	if(flag) return ;
	if(c==n)
	{
		flag=true; return ;
	}
	for(int i=0,sz=G[u].size();i<sz;i++)
	{
		int v=G[u][i];
		if(vis[v]==true) continue;
		vis[v]=true;
		dfs(v,c+1);
		vis[v]=false;
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	while(scanf("%d",&n)!=EOF)
	{
		memset(du,0,sizeof(du));
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++) 
		{
			G[i].clear(); fa[i]=i;
		}

		for(int i=0;i<n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			G[u].push_back(v); G[v].push_back(u);
			du[u]++; du[v]++;
			Union(u,v);
		}
		int st=1,g=Find(st);
		bool ok=true;
		for(int i=2;i<=n;i++)
		{
			if(du[i]<du[st]) st=i;
			if(Find(i)!=g) ok=false;
		}
		if(ok==false) 
		{
			puts("NO"); continue;
		}
		flag=false;
		vis[st]=true;
		dfs(st,1);
		if(flag) puts("YES");
		else puts("NO");
	}
    
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值