HDU4763 Theme Section 【KMP】

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1114    Accepted Submission(s): 579


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
  
  
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
  
  
0 0 1 1 2

做这题时感觉很愉快,因为coding时用的编辑器从单调的notepad++换成了炫酷的sublime,那配色方案、主题看着舒服多了,第二个原因是这题一次性通过~。

题意:给定一个字符串,长度在10^6之内,让这个字符串去匹配EAEBE形式的串,其中AB是任意长度的串(可为0),求E串最长是多少。

题解:首先求出给定主串的next数组,可以确定的是,若主串符合EAEBE形式,那么设next[len]==i,则在范围j属于[2*i, len-i]范围内一定有next[j]==i,这样题目就可解了。

#include <stdio.h>
#include <string.h>
#define maxn 1000002

char str[maxn];
int next[maxn];

void getNext()
{
	int i = 0, j = -1;
	next[0] = -1;
	while(str[i]){
		if(j == -1 || str[i] == str[j]){
			++i; ++j;
			next[i] = j; //mode 1
		}else j = next[j];
	}
}

int KMP()
{
	getNext();
	int i, j, len = strlen(str);

	for(i = next[len]; i; i = next[i]){
		for(j = i << 1; j <= len - i; ++j){
			if(next[j] == i) return i;
		}			
	}

	return 0;
}

int main()
{
	//freopen("stdin.txt", "r", stdin);
	int cas;
	scanf("%d", &cas);
	while(cas--){
		scanf("%s", str);
		printf("%d\n", KMP());
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值