Theme Section

Description

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'. 

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us? 
 

Input

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song. 
 

Sample Input

    
    
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output

    
    
0 0 1 1

2

这个问题主要意思是要让你把给出的字符串分成前后中三部分,并且三部分要完全相同,不能重叠在一起

我的做法:先找出三个部分的每个部分的最长长度;

从第一个字符开始,逐步测试前后是否相等;若前后相等,那么再找中间是否有符合的字符串,这个时候就要借助kmp算法了

具体代码如下

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
char a[10000005];
char b[10000005];
int next[10000005];
void getnext(char  *p){
    int i,j,k;
    next[0]=-1;
    j=0;
    k=-1;
    int len=strlen(p);
    while(j<len){
        if(k==-1||p[j]==p[k]){
            ++j;
            ++k;
            if(p[k]!=p[j]) next[j]=k;
            else next[j]=next[k];
        }
        else k=next[k];
    }
}
int main()
{
    int i,j,k;
    int num,m,n;
    int len;
    int l;
    int flag;
    int max,count;
    scanf("%d",&num);
    while(num--){
        scanf("%s",a);
        len=strlen(a);
        l=len/3;
        max=0;
        if(l>0){
            count=0;
            max=0;
            for(i=0;i<l;i++){
                count++;
                b[i]=a[i];
                flag=0;//puts(b);
                for(j=0;j<=i;j++){
                    if(b[j]!=a[len-count+j]){flag=1;break;}
                }
                if(flag==0){
                    getnext(b);
                    m=i+1;
                    n=0;
                    while(m<len-i-1&&n<=i){

                        if(n==-1||a[m]==b[n]){
                            ++m;
                            ++n;
                        }
                        else n=next[n];
                        if(n==i+1){
                            max=i+1;
                            break;
                        }
                    }
                }
                //else break;
            }
            memset(b,'\0',sizeof(b));
        }
        printf("%d\n",max);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值