Theme Section( 扩展 KMP )

Theme Section( 扩展 KMP )

题目

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ' EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input
6
xy
abc
aaa
aaaaba
aaxoaaaaa
aaaaabaaa
Sample Output
0
0
1
1
2
2

题意

题意是在一个字符串中找出一个前缀一个后缀和一个中间的子串,互相不重叠并且三部分完全一样

思路

既然是三个部分不重叠,那么每个部分就不可能超过全长的 1/3 。可以先看后面的再看前面的再看中间的,所以首先后面的直接从 大于等于 2/3 的地方开始判断。

  • 先用extend数组判断字符串后缀是否等于前缀。如果相等的话,由extend的性质得 nex[i]+i==len
  • 然后就是中间的,当然注意从哪开始到哪结束,易得 范围是 [nex[i],i) 。当然还要完全一样,所以中间的长度可能不够(跳过),可能一样长(符合条件),或者更长(符合条件)的情况。

题解

#include <iostream>
#include <cstring>

using namespace std;

char str[1000050];
int nex[1000050];
int len;
void getNext()
{
    int p = 0, a = 0;
    nex[0] = len;
    for (int i = 1; i < len; i++)
    {
        if (i >= p || i + nex[i - a] >= p)
        {
            if (i >= p)
                p = i;
            while (p < len && str[p] == str[p - i])
                p++;
            nex[i] = p - i;
            a = i;
        }
        else
            nex[i] = nex[i - a];
    }
}

int main()
{
    int T;
    cin >> T;
    while (T--)
    {
        cin >> str;
        len = strlen(str);
        getNext();
        int s = len / 3;
        int res = 0;
        for (int i =len- s; i < len; i++)
        {
            if (nex[i] + i == len)
            {
                for (int j = nex[i]; j < i; j++)
                {
                    if (nex[j] >= nex[i])
                        res = max(res, nex[i]);
                }
            }
        }
        cout << res << endl;
    }
}

转载于:https://www.cnblogs.com/tttfu/p/11307694.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值