POJ1159 Palindrome 【动态规划】

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 52571 Accepted: 18124

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
题意:给定一个串,求最小加入几个字符能使其变成回文串。

题解:找出原串的逆串,再求n - LCS即得结果,原理是原串和逆串构成的公共序列必定是回文的,所以,对于那些不能匹配成回文的字符只需要在它与回文串中心对称的位置加上一个同样的字符即构成回文。

#include <stdio.h>
#include <string.h>
#define maxn 5002

char str1[maxn], str2[maxn];
short dp[maxn][maxn];

void getTraverse(int len)
{
	int i = 1;
	while(len) str2[i++] = str1[len--];
	str2[i] = '\0';
}

int max(short a, short b){
	return a > b ? a : b;
}

int LCS(int len)
{
	int i, j;
	memset(dp, 0, sizeof(dp));
	for(i = 1; i <= len; ++i){
		for(j = 1; j <= len; ++j)
			if(str1[i] == str2[j]) dp[i][j] = dp[i-1][j-1] + 1;
			else dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
	}
	return dp[len][len];
}

int main()
{
	int n, len;
	while(scanf("%d", &n) == 1){
		scanf("%s", str1 + 1);
		len = strlen(str1 + 1);
		getTraverse(len);
		printf("%d\n", len - LCS(len));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值