poj1159 动态规划

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 45846 Accepted: 15629

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source


设原序列S的逆序列为S' ,则这道题目的关键在于,

最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子串长度
这个公式我不证明,不难证
剩下的就小意思了,最基础的LCS题。

滚动数组: 这里重点讲一下滚动数组在这个题目中的应用.自己目前理解的应用滚动数组的目的就是减少空间开销.首先可以在纸上简单模拟一下DP的转移过程.确定好最少行数或者列数之后,重点就是在如何进行"滚动"以及如何用表达式控制这个滚动.

对于本题,我用的是行数以0--1--0—1的滚动方式滚动表达式为i%2和(i-1)%2 ,就是强大的求余滚动 

代码:
#include <iostream>
#include<stdio.h>
#include<iomanip>
using namespace std;
int dp[2][5005];int n;
void solve(char s1[],char s2[])
{
	
	for(int i=0;i<=n-1;i++)
		for(int j=0;j<=n-1;j++)
		{
			if (s1[i]==s2[j])
			{
				dp[(i+1)%2][j+1]=dp[i%2][j]+1;

			}
			else
			{
				dp[(i+1)%2][j+1]=max(dp[i%2][j+1],dp[(i+1)%2][j]);
			}
		}
	cout<<n-dp[n%2][n]<<endl;
}
int main()
{
	
	cin>>n;
	char s1[5005],s2[5005];
	char temp;int j=n-1;
	for(int i=0;i<=n-1;i++)
	{
		
		cin>>temp;
		s1[i]=temp;
		s2[j]=temp;j--;

	}
	s1[n]='\0';s2[n]='\0';
	solve(s1,s2);
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值