Heavy Transportation
Time Limit: 3000MS | Memory Limit: 30000K | |
Total Submissions: 21037 | Accepted: 5569 |
Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.
Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1 3 3 1 2 3 1 3 4 2 3 5
Sample Output
Scenario #1: 4
Source
TUD Programming Contest 2004, Darmstadt, Germany
题意:求点1到n的最小割。
先尝试了下DFS,结果TLE。
#include <stdio.h>
#include <string.h>
#define maxn 1010
#define maxm maxn * maxn
#define inf 0x3f3f3f3f
int head[maxn], n, m, id, ans, cas = 1;
struct Node {
int v, c, next;
} E[maxm];
bool vis[maxn];
void addEdge(int u, int v, int c) {
E[id].v = v; E[id].c = c;
E[id].next = head[u]; head[u] = id++;
E[id].v = u; E[id].c = c;
E[id].next = head[v]; head[v] = id++;
}
void getMap() {
int u, v, c; id = 0;
scanf("%d%d", &n, &m);
memset(head, -1, sizeof(int) * (n + 1));
while(m--) {
scanf("%d%d%d", &u, &v, &c);
addEdge(u, v, c);
}
}
void DFS(int k, int dis) {
if(k == n) {
if(dis > ans) ans = dis;
return;
}
for(int i = head[k]; i != -1; i = E[i].next) {
if(!vis[E[i].v]) {
int pre = dis;
vis[E[i].v] = 1;
if(E[i].c < dis) dis = E[i].c;
DFS(E[i].v, dis);
dis = pre; vis[E[i].v] = 0;
}
}
}
void solve() {
ans = 0;
memset(vis, 0, sizeof(bool) * (n + 1));
vis[1] = 1; DFS(1, inf);
printf("Scenario #%d:\n%d\n\n", cas++, ans);
}
int main() {
// freopen("stdin.txt", "r", stdin);
int t;
scanf("%d", &t);
while(t--) {
getMap();
solve();
}
return 0;
}
然后尝试了下Dijkstra,过了..dis数组存储当前点到源点的最小割。
#include <stdio.h>
#include <string.h>
#define maxn 1010
#define maxm maxn * maxn
#define inf 0x3f3f3f3f
int head[maxn], n, m, id, ans, cas = 1;
struct Node {
int v, c, next;
} E[maxm];
int dis[maxn];
bool vis[maxn];
int max(int a, int b) {
return a > b ? a : b;
}
int min(int a, int b) {
return a < b ? a : b;
}
void addEdge(int u, int v, int c) {
E[id].v = v; E[id].c = c;
E[id].next = head[u]; head[u] = id++;
E[id].v = u; E[id].c = c;
E[id].next = head[v]; head[v] = id++;
}
void getMap() {
int u, v, c; id = 0;
scanf("%d%d", &n, &m);
memset(head, -1, sizeof(int) * (n + 1));
while(m--) {
scanf("%d%d%d", &u, &v, &c);
addEdge(u, v, c);
}
}
int getNext() {
int pos = -1, val = 0;
for(int i = 1; i <= n; ++i)
if(dis[i] > val && !vis[i]) {
val = dis[i]; pos = i;
}
return pos;
}
void Dijkstra(int start, int end) {
memset(dis, 0, sizeof(int) * (n + 1));
dis[start] = inf;
int i, u = start, v;
while(u != -1) {
vis[u] = 1;
if(u == end) return;
for(i = head[u]; i != -1; i = E[i].next) {
if(!vis[v = E[i].v]) dis[v] = max(dis[v], min(E[i].c, dis[u]));
}
u = getNext();
}
}
void solve() {
memset(vis, 0, sizeof(bool) * (n + 1));
Dijkstra(1, n);
printf("Scenario #%d:\n%d\n\n", cas++, dis[n]);
}
int main() {
// freopen("stdin.txt", "r", stdin);
int t;
scanf("%d", &t);
while(t--) {
getMap();
solve();
}
return 0;
}