Heavy Transportation(最短路的变形 Dijkstra算法)

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

本题的意思是求原点到N点的最大承重的最小值。

#include<stdio.h>
#include<string.h>
int map[1010][1010];//用 map 矩阵 表示各点之间的关系 
int dis[1010];//储存起始点到各个点的承重值 
int book[1010];//用来标记已加入的点 
int main()
{
	int T;
	int n, m;
	int i, j, k;
	int t1, t2, t3, Z;
	scanf("%d", &T);
	int count = 0;
	while (T--)
	{
		scanf("%d%d", &n, &m);
		for (i = 1; i <= n; i++) //将矩阵初始化 
			for (j = 1; j <= n; j++)
				if (i == j)
					map[i][j] = 0;
				else
					map[i][j] = -1;
		for (i = 1; i <= m; i++)//读入两点之间的承重值 
		{
			scanf("%d%d%d", &t1, &t2, &t3);
			map[t1][t2] = t3;
			map[t2][t1] = t3;
		}
		for (i = 1; i <= n; i++)//将1到各个顶点的承重值初始化 
			dis[i] = map[1][i];
		memset(book, 0, sizeof(book));
		book[1] = 1;
		for (i = 1; i <= n - 1; i++)
		{
			int max = 0;
			for (j = 1; j <= n; j++)
			{
				if (book[j] == 0 && dis[j] > max)//找出距离原点承重值最大且未加入的点 
				{
					max = dis[j];
					Z = j;
				}
			}
			book[Z] = 1;//标记该点已加入 
			for (k = 1; k <= n; k++)
			{
				if (book[k]==0&&dis[k]<dis[Z]&&dis[k]<map[k][Z])//如果原点到 k的承重小于原点到 Z 的 且 原点到k 的承重 小于k到Z的时候  
				{
					if (dis[Z] > map[k][Z])//取两者之间的最小承重,这样才能不破坏道路 
						dis[k] = map[k][Z];
					else
						dis[k] = dis[Z];
				}
			}
		}
		printf("Scenario #%d:\n", ++count);
		printf("%d\n\n", dis[n]);
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值