UVA OJ-401 回文词



                                               Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A""T""O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


感觉是很麻烦的一道题,对一个字符串要判断四种情况:

1)回文+镜像 2)回文+非镜像 3)非回文+镜像 4)什么都不是

先分类讨论。

第一种情况是最容易的,要做到回文+镜像,只要满足两个条件:

1、将字符串反转过来,处理后的字符串和原字符串相同。

2、其中所有的字符都符合(反转后还是原字符)的标准。 符合这个标准的字符只有这几个:

A H I M O T U V W X Y 1 0 8


由此编写代码如下:

    while (cin>>s1;)
    {
        int len=s1.length();
        int flag_huiwen=1,flag_jingxiang=1;
        for(int i=0;i<len/2;i++)
        {
            if(s1[i]!=s1[len-1-i]) {flag_huiwen=0;break;}
        }
        for(int i=0;i<len/2;i++)
        {
            if(s1[i]!='A' && s1[i]!='H' && s1[i]!='I' && s1[i]!='M'
            && s1[i]!='O' && s1[i]!='T' && s1[i]!='U' && s1[i]!='V'
            && s1[i]!='W' && s1[i]!='X' && s1[i]!='Y' && s1[i]!='1'
            && s1[i]!='0' && s1[i]!='8') {flag_jingxiang=0;}
        }
        if (flag_huiwen==1 && flag_jingxiang==1) { cout<<s1<<" -- is a mirrored palindrome."<<endl; continue; }
    }
    

第二种情况也是满足两个条件:

1、将字符串反转过来,处理后的字符串和原字符串相同。

2、其中的字符不满足镜像对称。

第一种情况不用说,按照上面的写法就可以了。但关键是第二个条件。该怎么办呢?

关键是要利用好上面那个表格,列成数组如下:

char one[]="ABCDEFGHIJKLMNOPQRSTUVWXYZ123456789";
char two[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";

接下来,对于剩余的两种情况,只要编写相应的判断函数即可说明。

另外要说明的一点是,这道题有个坑,每个判断过后都有一空行,结果又是WA了好几次。

最终AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
char one[]="ABCDEFGHIJKLMNOPQRSTUVWXYZ123456789";
char two[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";

int palin(char str[])
{
    int i, j;
    j=strlen(str)-1;
    for (i=0; i<=j; i++, j--)
    {
        if(str[i] != str[j])
        {
            return 0;
        }
    }
    return 1;
}

int pos(char ch)
{
    int len=35, i;
    for(i=0;i<len;i++)
      if(one[i]==ch)
        return i;
    return len;
}

int mirror(char str[])
{
    int i, t, k=strlen(str)-1;
    for (i=0; i<=k; i++, k--)
    {
        t=pos(str[i]);
        if (str[k] != two[t])
        {
            return 0;
        }
    }
    return 1;
}

int main()
{
    int n, m, i;
    char str[10000];
    while(cin>>str)
    {
        n=palin(str);
        m=mirror(str);
        if (!n && !m)
        {  cout<<str<<" -- is not a palindrome."<<endl<<endl; continue;}
        if (n && !m)
        {  cout<<str<<" -- is a regular palindrome."<<endl<<endl; continue;}
        if (!n && m)
        {  cout<<str<<" -- is a mirrored string."<<endl<<endl; continue;}
        if (n && m)
        {  cout<<str<<" -- is a mirrored palindrome."<<endl<<endl; continue;}
    }
    return 0;
}


嗯。看起来好像很不错,很直观。但是你知道我搞这段代码搞了多久吗!!!多久吗!!!老子要疯了!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值