uvaoj-401:回文词

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string 
"3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string 
"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A""T""O", and "Y"are all their own reverses.


A list of all valid characters and their reverses is as follows.


CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


题解:比较简单的一道题,lrj大神的代码是相当的简洁啊,但是考虑到笔者现在比较菜,想不到msg[m*2+p],这种高端表述,所以依旧沿用最传统的四个判断语句咯~


code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
using namespace std;
char mir[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";

char print[4][55]={"is not a palindrome.","is a regular palindrome.","is a mirrored string.","is a mirrored palindrome."};

int main()
{
    char ans[1005];
    char mirans[1005];
    bool flagrev,flagmir;//立了两个flag,一个判定回文,一个判定镜像;
    while(~scanf("%s",ans))
    {
        int len=strlen(ans);
        flagrev=1;
        for(int i=0; i<(len+1)/2; i++)
        {
            if(ans[i]!=ans[len-i-1])
            {
                flagrev=0;
                break;
            }
        }
        flagmir=1;
        for(int i=0; i<len; i++)
        {
            if(isalpha(ans[i])) mirans[i]=mir[ans[i]-'A'];//这里需要判定,因为数字和大写字母在ascii里面不是连续的;
            if(isdigit(ans[i])) mirans[i]=mir[ans[i]-'1'+26];
            if(mirans[i]!=ans[len-i-1])
            {
                flagmir=0;
                break;
            }
            //cout<<mirans[i];//这是用来测试的语句;
        }
        //cout<<endl;
        if(!flagmir&&!flagrev) cout<<ans<<" -- "<<print[0]<<endl;
        if(!flagmir&&flagrev) cout<<ans<<" -- "<<print[1]<<endl;
        if(flagmir&&!flagrev) cout<<ans<<" -- "<<print[2]<<endl;
        if(flagmir&&flagrev) cout<<ans<<" -- "<<print[3]<<endl;
        cout<<endl;

    }
    return 0;
}

笔记:uvaoj不想hdoj那样有pe这个错误提示,笔者吧输出里面的两个减号当成了——,进而卡了半个小时,脸红啊。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值