[BFS]HDU1045 Fire Game

I - Fire Game
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input
The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input
4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#
Sample Output
Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意:一块n*m的地盘,里面要么是空地要么是草地,现在两个小盆友选择其中的两块草地点燃,火势会往四个方向蔓延,问把所有草地烧光需要的最短时间。如果不能烧光,输出-1

枚举两块草地,直接做bfs即可。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;

const int INF = 0x3f3f3f3f;
int n,m;
char map[15][15];

struct node
{
    int x;
    int y;
    int id;
    int step;
}p[110];
int cnt;
queue<node> que;

int bfs(int s1, int s2)
{
    int vis[110];
    int ans = -1;
    while(!que.empty()) que.pop();
    memset(vis,0,sizeof(vis));  //清空
    vis[s1] = 1;
    vis[s2] = 1;
    que.push((struct node) {p[s1].x, p[s1].y, p[s1].id, 0});
    que.push((struct node) {p[s2].x, p[s2].y, p[s2].id, 0});

    while(!que.empty())
    {
        struct node u = que.front();
        que.pop();

        int step = u.step;
        int i = u.x;
        int j = u.y;
        int id;

        if(ans < step) ans = step;

        if(map[i][j-1] != '.' && !vis[ u.id -1 ])
        {
            vis[u.id - 1] = 1;
            que.push((struct node) {p[u.id-1].x, p[u.id-1].y, p[u.id-1].id,step+1});
        }
        if(map[i][j+1] != '.' && !vis[ u.id+1 ])
        {
            vis[u.id+1] = 1;
            que.push( (struct node) {p[u.id+1].x, p[u.id+1].y, p[u.id+1].id,step+1});
        }
        if(map[i-1][j] != '.')
        {
            for(int k = 1; k <= cnt; k++)
            {
                if(p[k].x == i-1 && p[k].y == j)
                {
                    id = p[k].id;
                    break;
                }
            }
            if(!vis[id])
            {
                vis[id] = 1;
                que.push((struct node) {p[id].x, p[id].y, p[id].id, step+1} );
            }
        }
        if(map[i+1][j] != '.')
        {
            for(int k = 1; k <= cnt; k++)
            {
                if(p[k].x == i+1 && p[k].y == j)
                {
                    id = p[k].id;
                    break;
                }
            }
            if(!vis[id])
            {
                vis[id] = 1;
                que.push((struct node) {p[id].x, p[id].y, p[id].id, step+1} );
            }
        }
    }

    for(int k = 1; k <= cnt; k++)
    {
        if(vis[k] == 0)
        {
            ans = -1;
            break;
        }
    }
    return ans;
}

int main()
{
    int test;
    scanf("%d",&test);
    for(int item = 1; item <= test; item++)
    {
        scanf("%d %d",&n,&m);
        cnt = 0;
        for(int i = 1; i <= n; i++)
        {
            scanf("%s",map[i]+1);
            for(int j = 1; j <= m; j++)
                if(map[i][j] == '#')
                    p[++cnt] = (struct node){i,j,cnt};
        }

        for(int i = 0; i <= n+1; i++)
        {
            map[i][0] = '.';
            map[i][m+1] = '.';
        }

        for(int i = 0; i <= m+1; i++)
        {
            map[0][i] = '.';
            map[n+1][i] = '.';
        }

        if(cnt == 1)        //只有一块草地时
        {
            printf("Case %d: 0\n",item);
            continue;
        }

        int tmp,ans = INF;
        for(int i = 1; i <= cnt-1; i++)
        {
            for(int j = i+1; j <= cnt; j++)
            {
                tmp = bfs(i,j); //枚举两块草地
                if(tmp != -1 && ans > tmp)
                    ans = tmp;
            }
        }
        printf("Case %d: ",item);
        if(ans == INF)
            printf("-1\n");
        else printf("%d\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值