[二分]poj 1064 Cable Master

M - Cable master
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00

有N条绳子,他们的长度分别为Li,如果从他们中切出K条长度相同的绳子,那么这K条绳子每条有多长?结果保留两位小数。

这个问题用二分搜索的方法很容易求得答案。
设置上界为INF,下界为0,
check(x)表示可以得到K条长度为x的绳子。

唯一需要注意的点是小数精度问题:在这个代码中使用的是for循环来指定二分搜索的次数,也可以使用
while( ub - lb > 0.0000001)
来指定一个区间的大小,从而达到所需要的输出精度。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=1e5+100;
const int INF = 0x3f3f3f3f;
int N,K;
double L[maxn];

bool check(double x)
{
    int num = 0;
    for(int i = 0;i<N;i++)
        num += (int) (L[i] /x);
    return num>=K;
}

int main()
{
    scanf("%d%d",&N,&K);
    for(int i = 0; i < 4; i++)
        scanf("%lf",&L[i]);
    double lb = 0,ub =INF;
    for(int i = 0; i< 100;i++)
    {
        double mid = (lb+ub) / 2;
        if(check(mid)) lb = mid;
        else ub = mid;
    }
    printf("%.3f\n",floor(ub*100)/100);
    return 0;
}

像这样,在求解最大化或者最小化问题中,如果可以比较简单地判断条件是否满足,那么使用二分搜索法就可以很好地解决问题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值