[二分+贪心] poj 2456 Aggressive cows

N - Aggressive cows
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Line i+1 contains an integer stall location, xi
    Output
  • Line 1: One integer: the largest minimum distance
    Sample Input
    5 3
    1
    2
    8
    4
    9
    Sample Output
    3
    Hint
    OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

还是二分,上界INF,下界为0。
check(d) 表示是否可以安排牛的位置使得最近的两头牛的距离不小于d。
很容易用贪心求解:
1、对牛舍的位置进行排序
2、把第一头牛放入x0的牛舍
3、将下一头牛放入满足距离刚好大于或等于d的上一头牛的牛舍中

#include <iostream>
#include <algorithm>
#include<cstdio>
using namespace std;
const int MAXN = 100010;
const int INF =0X3f3f3f3f;
int N,M;
int x[MAXN];
bool check(int d)
{
    int last = 0;
    for(int i = 1; i < M; i++)
    {
        int now = last + 1;
        while(now < N && x[now]- x[last] < d)
            now++;
        if (now == N) return false;
        last = now;
    }
    return true;

}

int main()
{
    scanf("%d%d",&N,&M);
    for(int i = 0; i < N;i++)
        scanf("%d",&x[i]);
    sort(x,x+N);
    int lb = 0,ub = INF;
    while(ub - lb > 1)
    {
        int mid = (lb + ub) /2;
        if (check(mid)) lb = mid;
        else ub = mid;
    }
    printf("%d\n",lb);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值