[二分]poj2976 Dropping tests

E - Dropping tests
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
Sample Output
83
100

输入数组a和数组b,总共n对中可以去掉k对,求其中n-k对∑a[i]/∑b[i]的最大值。


假设我们要求这个式子的最大值,那么如何解这个式子呢?   假设这个式子的最大值,也就是最优解为val,即val=max(a*x/b*x)。 

设置这样一个子问题:q(L)=a*x-b*x*L,然后我们分配向量x,来使q(L)取得最大值max,注意:这个式子不是一下能算出来的,因为a,b,x都是向量,如果向量是m维的,那么我们应该把算出来的m个数求和。

这时q(L)的最大值max就分两种情况来看:
①max<0 ,即a*x-b*x*L<0 ---->
 a*x<b*x*L  ----> (a*x)/(b*x) <L ,
 那么无论怎么分配x都没法到达L值,即val<L,所以解要比L小,我们应该适当减小L的值再试。

②max>=0 即val>=L,  且进一步还知道,当取到L=val时,有a*x-b*x*L=0,所以此时解要>=L,那么我们应当增大L的值再试。

上面两种情况已经可以看出,我们可以二分L。

说到这,上面说的要想策略,策略就是:分配x,使q(L)=a*x-b*x*L最大,我们需要求出n个t[i]=a[i]-b[i]*L,然后对t排序,取前n-k组最大的即可。
#include <iostream>
#include <algorithm>
#include<cstdio>
using namespace std;
const int MAXN = 100010;
const int INF =0X3f3f3f3f;
const double eps = 1e-6;
int n,k;
double a[MAXN],b[MAXN],t[MAXN];

int cmp(double x,double y)
{
    return x>y;
}

bool does(double num)
{
    for(int i = 0; i< n;i++)
        t[i] = a[i]- num * b[i];
    sort(t,t+n,cmp);
    double sum = 0.0;
    for(int i = 0;i<n-k;i++)
        sum += t[i];
    return sum > 0;
}

int main()
{
    while(scanf("%d%d",&n,&k))
    {
        if (n==0 && k ==0 ) break;
        for(int i = 0;i<n;i++)
            scanf("%lf",&a[i]);
        for(int i = 0;i<n;i++)
            scanf("%lf",&b[i]);

        double lb = 0.0,ub = 1.0;
        while( ub-lb > eps )
        {
            double mid = (ub+lb)/2.0;
            if (does(mid)) lb = mid;
            else ub = mid;
        }
        printf("%d\n",(int)(ub*100+0.5));
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值