MZL’s xor
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1509 Accepted Submission(s): 619
Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
The xor of an array B is defined as B1 xor B2…xor Bn
Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z) mod l
1≤m,z,l≤5∗105,n=5∗105
Output
For every test.print the answer.
Sample Input
2
3 5 5 7
6 8 8 9
Sample Output
14
16
可以发现当i!=j时,Ai+Aj会与Aj+Ai抵消,于是把所有的Ai * 2 给 Xor起来就好了。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;
long long A[550000];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n,m,z,l;
scanf("%d%d%d%d",&n,&m,&z,&l);
A[1]=0;
for(int i=2; i<=500000; i++)
{
A[i]=(A[i-1]*m+z)%l;
}
for(int i=2; i<=500000; i++)
A[i]=A[i]+A[i];
long long sum=0;
for(int i = 2; i<=n; i++){
sum^=A[i];
}
printf("%I64d\n",sum);
}
return 0;
}