[数学] 多校联合第五场 hdu5344 MZL's xor

MZL’s xor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1509 Accepted Submission(s): 619

Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
The xor of an array B is defined as B1 xor B2…xor Bn

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai−1∗m+z) mod l
1≤m,z,l≤5∗105,n=5∗105

Output
For every test.print the answer.

Sample Input
2
3 5 5 7
6 8 8 9

Sample Output
14
16

可以发现当i!=j时,Ai+Aj会与Aj+Ai抵消,于是把所有的Ai * 2 给 Xor起来就好了。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;

long long A[550000];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,z,l;
        scanf("%d%d%d%d",&n,&m,&z,&l);
        A[1]=0;
        for(int i=2; i<=500000; i++)
        {
            A[i]=(A[i-1]*m+z)%l;
        }
        for(int i=2; i<=500000; i++)
            A[i]=A[i]+A[i];

        long long sum=0;
        for(int i = 2; i<=n; i++){
            sum^=A[i];
        }
        printf("%I64d\n",sum);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值