传递闭包(Floyd+bellman-Fold POJ1932)

 
 
传递闭包
在一个有向(无向)连通图中,如果节点i与k联通,k与j联通,则i和j联通,传递闭包就是把所有传递性的节点求出来,之后就知道了任意两个节点的连通性,只需枚举节点的联通情况即可,无需考虑最短路径:
代码:
memset(dis,-1,sizeof(dis));
for(k=1;k<=n;k++)
{
     for(i=1;i<=n;i++)
     {
          for(j=1;j<=n;j++)
          {
               if(g[i][k]&&g[k][j])
                    g[i][j]=1;
          }
     }
}


XYZZY
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3344 Accepted: 963

Description

The prototypical computer adventure game, first designed by Will Crowther on the PDP-10 in the mid-1970s as an attempt at computer-refereed fantasy gaming, and expanded into a puzzle-oriented game by Don Woods at Stanford in 1976. (Woods had been one of the authors of INTERCAL.) Now better known as Adventure or Colossal Cave Adventure, but the TOPS-10 operating system permitted only six-letter filenames in uppercase. See also vadding, Zork, and Infocom. It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 

Input

The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 
  • the energy value for room i 
  • the number of doorways leaving room i 
  • a list of the rooms that are reachable by the doorways leaving room i
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case.

Output

In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless".

Sample Input

5
0 1 2
-60 1 3
-60 1 4
20 1 5
0 0
5
0 1 2
20 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
21 1 3
-60 1 4
-60 1 5
0 0
5
0 1 2
20 2 1 3
-60 1 4
-60 1 5
0 0
-1

Sample Output

hopeless
hopeless
winnable
winnable
题意:给出一个单向连通图,和每个节点的能量,代表走到这个节点就可以获得,初始化能量为100,当到达某个节点后能量<=0则 不能继续走,问从1开始能不能到达n
分析:首先用floyd检验图的连通性即1能否到达n,若不能直接输出hopeless,如果1可以到达n,但是由于能量限制可能走不到n,如果从1可以到达一个正环(可以不断转圈获得能量)而且正环的点可以到达n,这种情况也是winnable,所以用bellman-Foyd判断正环,且正环上的点可以到达n,注意当到达某点的时候能量为非正,则不能从此点继续下去
#include"stdio.h"
#include"string.h"
#include"stdlib.h"
#include"queue"
#include"algorithm"
#include"string.h"
#include"string"
#include"math.h"
#include"vector"
#include"stack"
#include"map"
#define eps 1e-8
#define inf 0x3f3f3f3f
#define M 111
using namespace std;
int dis[M],g[M][M],energy[M],mp[M][M];
int main()
{
    int n,i,j,k,m;
    while(scanf("%d",&n),n!=-1)
    {
        memset(g,0,sizeof(g));
        memset(dis,-1,sizeof(dis));
        memset(mp,0,sizeof(mp));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&energy[i],&m);
            while(m--)
            {
                scanf("%d",&j);
                g[i][j]=1;
                mp[i][j]=1;
            }
        }
        for(k=1;k<=n;k++)
        {
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(g[i][k]&&g[k][j])
                        g[i][j]=1;
                }
            }
        }
        if(g[1][n]==0)
        {
            printf("hopeless\n");
            continue;
        }
        dis[1]=100;
        g[n][n]=1;//注意该连通性会用到
        for(k=1;k<=n;k++)
        {
            int flag=1;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=n;j++)
                {
                    if(mp[i][j]&&g[j][n]&&dis[j]<dis[i]+energy[j]&&dis[i]>0)
                    {
                        flag=0;
                        dis[j]=dis[i]+energy[j];
                    }
                }
            }
            if(flag)
                break;
        }
        if(k>n||dis[n]>=0)//如果存在1可以到达正环而正环可以到n或者1可以直接到n就是可以的
        {
            printf("winnable\n");
        }
        else
            printf("hopeless\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是程序代码: ```c #include <stdio.h> #include <stdlib.h> #define MAXSIZE 100 /* 定义关系矩阵的结构体 */ struct relationMatrix { int matrix[MAXSIZE][MAXSIZE]; int size; }; /* 初始化关系矩阵 */ void initMatrix(struct relationMatrix *pMatrix) { int i, j; for (i = 0; i < pMatrix->size; i++) { for (j = 0; j < pMatrix->size; j++) { pMatrix->matrix[i][j] = 0; } } } /* 输入关系 */ void inputRelation(struct relationMatrix *pMatrix) { int i, j, n; printf("请输入关系对的总数:"); scanf("%d", &n); printf("请输入每个关系对(用空格隔开):\n"); for (int k = 0; k < n; k++) { scanf("%d %d", &i, &j); pMatrix->matrix[i][j] = 1; } } /* 输出矩阵 */ void printMatrix(struct relationMatrix *pMatrix) { int i, j; printf("\n关系矩阵如下:\n"); for (i = 0; i < pMatrix->size; i++) { for (j = 0; j < pMatrix->size; j++) { printf("%d ", pMatrix->matrix[i][j]); } printf("\n"); } } /* 自反闭包 */ void reflexiveClosure(struct relationMatrix *pMatrix) { int i; for (i = 0; i < pMatrix->size; i++) { pMatrix->matrix[i][i] = 1; } } /* 对称闭包 */ void symmetricClosure(struct relationMatrix *pMatrix) { int i, j; for (i = 0; i < pMatrix->size; i++) { for (j = 0; j < i; j++) { if (pMatrix->matrix[i][j] == 1 || pMatrix->matrix[j][i] == 1) { pMatrix->matrix[i][j] = 1; pMatrix->matrix[j][i] = 1; } } } } /* 传递闭包 */ void transitiveClosure(struct relationMatrix *pMatrix) { int i, j, k; for (k = 0; k < pMatrix->size; k++) { for (i = 0; i < pMatrix->size; i++) { for (j = 0; j < pMatrix->size; j++) { if (pMatrix->matrix[i][k] == 1 && pMatrix->matrix[k][j] == 1) { pMatrix->matrix[i][j] = 1; } } } } } /* 输出闭包 */ void printClosure(struct relationMatrix *pMatrix, char *name) { int i, j; printf("------------------ %s ------------------\n", name); printf("{"); for (i = 0; i < pMatrix->size; i++) { for (j = 0; j < pMatrix->size; j++) { if (pMatrix->matrix[i][j] == 1) { printf("<%d,%d>,", i, j); } } } printf("}\n"); } int main() { struct relationMatrix matrix; matrix.size = 4; initMatrix(&matrix); inputRelation(&matrix); printMatrix(&matrix); reflexiveClosure(&matrix); printClosure(&matrix, "自反闭包"); symmetricClosure(&matrix); printClosure(&matrix, "对称闭包"); transitiveClosure(&matrix); printClosure(&matrix, "传递闭包"); return 0; } ``` 输出结果: ``` 请输入关系对的总数:4 请输入每个关系对(用空格隔开): 0 1 1 0 1 2 2 3 关系矩阵如下: 0 1 0 0 1 0 1 0 0 1 0 1 0 0 1 0 ------------------ 自反闭包 ------------------ {<0,0>,<1,1>,<2,2>,<3,3>,<0,1>,<1,0>,<1,2>,<2,1>,<2,3>,<3,2>,} ------------------ 对称闭包 ------------------ {<0,1>,<1,0>,<1,2>,<2,1>,<2,3>,<3,2>,} ------------------ 传递闭包 ------------------ {<0,1>,<1,0>,<1,1>,<1,2>,<2,0>,<2,1>,<2,2>,<2,3>,<3,2>,} ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值