hdu4496 D-City(反向并查集啊 )

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4496



D-City

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 
Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 

Source

思路:
题目需要逆向思考(正向行不通的时候,我们不防换一条路
试试,生活亦是如此);
我们可以逆向认为所有的点全是独立的,因为正
向的时候去掉其中某条边的,独立的点不一定会增多(去掉这条边后还有
其他边间接的相连),所以当我们逆向思考的时候,只会在增加某一条边
时减少独立的点(也就是联通的点增多),这样只会在他之后才会有可能
有某条边的操作是“无效”的(联通的点不变);
#include <cstdio>
#include <cstring>
const int maxn = 100017;
int father[maxn];
int findd(int x)
{
    //return x==father[x] ? x : father[x]=findd(father[x]);
    if(father[x] == -1)
    {
        return x;
    }
    return father[x] = findd(father[x]);
}
int main()
{
    int n, m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i = 0; i < n; i++)
        {
            father[i] = -1;
        }

        int a[maxn], b[maxn], ans[maxn];

        for(int i = 1; i <= m; i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        ans[m] = n;
        for(int i = m; i > 1; i--)
        {
            int u, v;
            //scanf("%d%d",&u,&v);
            int f1 = findd(a[i]);
            int f2 = findd(b[i]);
            //printf("f1:%d f2:%d\n",f1,f2);
            if(f1 != f2)
            {
                ans[i-1] = ans[i]-1;
                father[f1] = f2;
            }
            else
            {
                ans[i-1] = ans[i];
            }
        }
        for(int i = 1; i <= m; i++)
        {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值