HDU 5056 Boring count(数学)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5056


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 
Output
For each case, output a line contains the answer.
 
Sample Input
  
  
3 abc 1 abcabc 1 abcabc 2
 
Sample Output
  
  
6 15 21
 
Source


官方题解:


代码如下:
#include <cstdio>
#include <cstring>
const int maxn = 100017;
int main()
{
    int t;
    char str[maxn];
    int st[27];
    int k;
    scanf("%d",&t);
    while(t--)
    {
        memset(st,0,sizeof(st));
        scanf("%s",str);
        scanf("%d",&k);
        __int64 ans = 0;
        int len = strlen(str);
        int startpos = 0;
        for(int i = 0; i < len; i++)
        {
            int tt = str[i] -'a';
            st[tt]++;
            if(st[tt] > k)
            {
                while(str[startpos]!=str[i])
                {
                    st[str[startpos]-'a']--;
                    startpos++;
                }
                st[str[startpos]-'a']--;
                startpos++;
            }
            ans+=i-startpos+1;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值