poj 1611The Suspects(简单的并查集求集合元素)

39 篇文章 0 订阅
7 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 22109 Accepted: 10746

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

题目大意:第一行输入n,m,n表示学生的人数,m表示一共的组数;
一下有m行,每行先输入一个k。然后紧跟着k个数,表示这一组中有k个人,k后面k个数就是在这个组的学生的编号;
现在已知,0号同学染病(此病可传染),和0号接触的同学都染病,输出最后染病同学的人数(即输出0号同学所在集合的元素个数)
代码:
#include <iostream>
#include<stdio.h>
#include<string.h>
#define MAX 30010
using namespace std;
struct Suspect
{
    int parent;//父节点指针
    int cnt;//计数
} set[MAX];
void make_set(int n)//初始化
{
    int i;
    for(i=0; i<n; i++)
    {
        set[i].parent=i;
        set[i].cnt=1;
    }
}
int set_find(int x)
{
    return set[x].parent==x?x:set[x].parent=set_find(set[x].parent);//查找并路径压缩
}
void set_join(int x,int y)//合并集合并计数
{
    int px=set_find(x);
    int py=set_find(y);
    if(px!=py)
    {
        set[py].parent=px;
        set[px].cnt+=set[py].cnt;
    }
}
int main()
{
    int n,m,i,j,k,a,b,ans;
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        make_set(n);
        for(i=0; i<m; i++)
        {
            scanf("%d %d",&k,&a);
            for(j=1;j<k;j++)
            {
                scanf("%d",&b);
                set_join(a,b);/合并集合
            }
        }
        ans=set[set_find(0)].cnt;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值