POJ 1611 The Suspects并查集统计集合元素个数

目录

The Suspects

Description

Input

Output

Sample Input

Sample Output

My Code and Note

 

The Suspects

Time Limit1000MSMemory Limit20000K
Total Submissions53051Accepted13149

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.


Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.


Output

For each case, output the number of suspects in one line.


Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


Sample Output

4
1
1
 

My Code and Note

#include<iostream>
using namespace std;
const int N = 3e4+5;
int father[N],a[N],ans[N];
int n,m;
int Find(int x)
{
    if(x==father[x]) return x;
    return father[x]=Find(father[x]);//路径压缩,节约大量查询时间,一次回溯即可使以后查询时间复杂度变为O(1)
}
void join(int x,int y)
{
    int fx=Find(x),
        fy=Find(y);//找祖先
    if(fx!=fy){//不同祖则合并
        father[fx]=fy;//(任取)令fy为fx的父亲(祖先)
        ans[fy]+=ans[fx];//将被合并集的总数加到父亲集中
    }
    return ;
}//合并集
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m,n||m){
        for(int i=0;i<n;i++){
            father[i]=i;
            ans[i]=1;
        }//开始时每个人自成一个集合,显然,各集合元素个数为1
        int t;
        while(m--){
            cin>>t;
            for(int i=1;i<=t;i++) cin>>a[i];
            for(int i=1;i<t;i++) join(a[i],a[i+1]);//相邻合并即可,不用两两合并,道理简单(祖先具有传递性,AB同祖,AC同祖,那么BC同祖,Find(A)=Find(B)=Find(C))
        }
        cout<<ans[Find(0)]<<endl;//输出0的祖先所在的集合的元素个数
    }
    return 0;
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值