poj 2255 Tree Recovery(二叉树的遍历)

Tree Recovery
点击打开题目链接
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11333 Accepted: 7107

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Source

Ulm Local 1997

给出二叉树的前序遍历,和中序遍历,输出二叉树的后序遍历;
二叉树的三种遍历规则:
  前序遍历:根-左子树-右子树;
  中序遍历:左子树-根-右子树;
  后序遍历:左子树-右子树-根;
易知,前序遍历的第一个字符和后根遍历的最后一个字符是树的根节点;
而中序遍历反映的是二叉树左右子树的结构,故如果知道前序遍历和中序遍历,就可以知道二叉树的后序遍历,或者知道后序遍历和中序遍历来确定二叉树的前序遍历;
此题就是前者;
例如:
    前序遍历为:BCAD ;
    中序遍历为:CBAD;
    则易知B为整个树的根节点,然后在中序遍历的串中找到该点,如果左边有字符,则递归左子树;如果右边有字符则递归右子树;
如果是后者,已知中序遍历和后序遍历求前序遍历,则后根遍历从最后一个字符向前递归,先输出再递归左子树和右子树
代码:
#include <stdio.h>
#include <string.h>
#define MAX 33
char dlr[MAX],ldr[MAX];
int len1;
void LRD(int ps,int pe,int ms,int me)
{
    int i,leftsize,rightsize;
    for(i=ms; i<=me; i++)
    {
        if(ldr[i]==dlr[ps])//在中序遍历中找到根节点的位置
        {
            break;
        }
    }
    leftsize=i-ms;//计算左子树的长度
    rightsize=me-i;//计算右子树的长度
    if(leftsize>0)
    {
        LRD(ps+1,ps+leftsize,ms,i-1);//递归左子树的前序遍历和中序遍历
    }
    if(rightsize>0)
    {
        LRD(ps+1+leftsize,pe,i+1,me);//递归右子树的前序遍历和有序遍历;
    }
        printf("%c",dlr[ps]);
}
int main()
{
    while(~scanf("%s%s",dlr,ldr))
    {
        len1=strlen(dlr);
        LRD(0,len1-1,0,len1-1);
        printf("\n");
        memset(dlr,'\0',sizeof(dlr));
        memset(ldr,'\0',sizeof(ldr));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值