poj 3254 Corn Fields(状态DP初探)

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8138 Accepted: 4339

Description

Farmer John has purchased a lush new rectangular pasture composed of M byN (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题目大意:给你一块草地,草地分为n*m的小块,其中有的小块可以放牛,有的不可以,题目中给出,同一小块只能放一种牛,且相邻的草地放得牛的种类不同,文一共有多少中放牛的方案。(注意结果mod1e8);

至于和状态DP有关,别人说如果n,m之类的范围在32之内,等比较小得数时,可以考虑一下状态DP。我认为状态dP就是把题目中的给出条件变为各个状态,动态规划递归求解。当然难点在于怎么把状态构造出来。只有找到合适的状态才能巧妙的运用上这个。

由于对于位运算的不熟悉,导致了好多wa,注意 (1<<m-1)和((1<<m)-1)是不一样的。
对于这个题,相对简单(不过我做了好长时间,O__O"…,渣爆了)。只要记录每一行的状态即可;
dp[i][k]表示第i行状态为k的时候的可行的方案数,状态转移方程为dp[i][k]=∑(dp[i-1][s]);
代码:
#include <iostream>
#include <string.h>
#include <stdio.h>
#define N 13
#define M 1<<13
#define mod 100000000
using namespace std;
int a[N];
long long dp[N][M];
int check1(int x)///检查是否有相邻的放相同种类的牛
{
    return !((x>>1)&x);//左移或右移后按位与
}
int check2(int x,int y)//判断两行的状态有没有上下相邻且种类相同的
{
    return !(x&y);//按位与
}
int check(int a,int x,int m)//检查有没有不能放缺放了的
{
    return !(x&(~a));//将a取反和x按位与
}
void slove(int n,int m)
{
    long long statue=1<<m;///2^m次方个状态
    int i,j,k;
    memset(dp,0,sizeof(dp));
    for(i=0; i<=statue; i++)//初始化
    {
        if(check(a[1],i,m)&&check1(i))
            dp[1][i]=1;
    }
    for(i=2; i<=n; i++)
    {
        for(j=0; j<=statue; j++)
        {
            if(check1(j)&&check(a[i],j,m))
            {
                for(k=0; k<=statue; k++)
                {
                    if(check2(j,k))
                        dp[i][j]=(dp[i][j]%mod+dp[i-1][k]%mod)%mod;
                }
            }
        }
    }
}
int main()
{
    int n,m,i,j,x;
    long long ans;
    while(~scanf("%d%d",&n,&m))
    {
        ans=0;
        long long statue=1<<m;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=m; j++)
            {
                scanf("%d",&x);
                a[i]=(a[i]<<1)+x;///压缩为二进制数
            }
        }
        slove(n,m);
        for(i=0; i<=statue; i++)//将最后一行的数求和
            ans=(ans%mod+dp[n][i]%mod)%mod;
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给出一个$n\times m$的矩阵,每个位置上有一个非负整数,代表这个位置的海拔高度。一开始时,有一个人站在其中一个位置上。这个人可以向上、下、左、右四个方向移动,但是只能移动到海拔高度比当前位置低或者相等的位置上。一次移动只能移动一个单位长度。定义一个位置为“山顶”,当且仅当从这个位置开始移动,可以一直走到海拔高度比它低的位置上。请问,这个矩阵中最多有多少个“山顶”? 输入格式 第一行两个整数,分别表示$n$和$m$。 接下来$n$行,每行$m$个整数,表示整个矩阵。 输出格式 输出一个整数,表示最多有多少个“山顶”。 样例输入 4 4 3 2 1 4 2 3 4 3 5 6 7 8 4 5 6 7 样例输出 5 算法1 (递归dp) $O(nm)$ 对于这道题,我们可以使用递归DP来解决,用$f(i,j)$表示以$(i,j)$为起点的路径最大长度,那么最后的答案就是所有$f(i,j)$中的最大值。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码 算法2 (动态规划) $O(nm)$ 动态规划的思路与递归DP类似,只不过转移方程和实现方式有所不同。 状态转移方程如下: $$ f(i,j)=\max f(x,y)+1(x,y)是(i,j)的下一个满足条件的位置 $$ 注意:这里的状态转移方程中的$x,y$是在枚举四个方向时得到的下一个位置,即: - 向上:$(i-1,j)$ - 向下:$(i+1,j)$ - 向左:$(i,j-1)$ - 向右:$(i,j+1)$ 实现过程中需要注意以下几点: - 每个点都需要搜一遍,因此需要用双重for循环来枚举每个起点; - 对于已经搜索过的点,需要用一个数组$vis$来记录,防止重复搜索; - 在进行状态转移时,需要判断移动后的点是否满足条件。 时间复杂度 状态数为$O(nm)$,每个状态转移的时间复杂度为$O(1)$,因此总时间复杂度为$O(nm)$。 参考文献 C++ 代码

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值