poj 1469 COURSES(判断是否是存在不匹配的点(对于右边的点集来说))

28 篇文章 1 订阅
11 篇文章 0 订阅
COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17858 Accepted: 7038

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

题目大意:有P门课和N个学生,第i门课有counti个学生学习;每个学习i课的学生均可代表这个课;

问能否找出学生,每个学生只代表一门课,并且,没有课时没有学生代表的;

题目大概是求,对于一个二分图的匹配,对于右边的集合(或者左边的集合)中的点,全是匹配点,不存在不匹配的点;

用匈牙利算法找出最大匹配后,便利右边集合中的点(或者左边集合中的点),看是否存在不匹配的点;

注意:此题如果用右集合中的点来考虑的话,注意在输入时应将顺序反一下。

代码:

#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <stdio.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define N 310
using namespace std;
int w[N][N];
int l[N];
int visit[N],v1,v2;
bool dfs(int x)
{
    int i;
    for(i=1;i<=v2;i++)
    {
        if(!visit[i]&&w[x][i])
        {
            visit[i]=1;
            if(l[i]==0||dfs(l[i]))
            {
                l[i]=x;
                return true;
            }
        }
    }
    return false;
}
int nmatch()
{
    int i;
    for(i=1;i<=v1;i++)
    {
        memset(visit,0,sizeof(visit));
        dfs(i);
    }
    for(i=1;i<=v2;i++)
    {
        if(!l[i])//遍历点看是否存在不匹配的点
            return 0;
          //  printf("l[i] %d\n",l[i]);
    }
    return 1;
}
int main()
{
    int t,p,q,n,i,j,d;
    int ans;
    scanf("%d",&t);
    {
        while(t--)
        {
            scanf("%d%d",&p,&n);
            v1=n,v2=p;//v1,v2的大小也要换一下
            memset(w,0,sizeof(w));
            memset(l,0,sizeof(l));
            for(i=1;i<=p;i++)
            {
                scanf("%d",&q);
                for(j=0;j<q;j++)
                {
                    scanf("%d",&d);
                    w[d][i]=1;///顺序反一下(注意到这应该就没问题了)
                }
            }
            ans=nmatch();
            printf("%s\n",ans==1?"YES":"NO");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值