HDU 2717 Catch That Cow 水题BFS

Catch That Cow
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10675 Accepted Submission(s): 3327

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

在X轴上,牛在K的地方,农夫在N的地方,牛不会动,农夫要从当前位置去找牛,农夫一次操作可以走N+1,N-1,2*N中的其中一种,问农夫找到牛需要的最短时间。
直接BFS就出来了,优先队列写习惯了,不管什么BFS我都会直接优先队列给写上去,会用但是不明白队列与优先队列的差别呀。



#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
int visited[200005];
int N,K;
int mina;
struct node{
    int x;  
    int step;
    friend bool operator <(node a,node b)
    {
        return a.step>b.step;
    }
};
void BFS()
{
    priority_queue<node>Q;  
    node cur,next;
    cur.x=N;
    cur.step=0;
    Q.push(cur);
    while(!Q.empty())
    {

        cur=Q.top();
        Q.pop();
        if(cur.x==K)
        {
            mina=cur.step;
            return;
        }
        for(int i=0;i<3;i++)
        {
            if(i==0)
            next.x=cur.x+1;
            else if(i==1)
            next.x=cur.x-1;
            else if(i==2)
            next.x=cur.x*2;
            next.step=cur.step+1;
            if(next.x==K)
            {
                mina=next.step;
                return;
            }
            if(visited[next.x]==0&&next.x<=100000&&next.x>=0)//这里的剪枝很重要,没这剪枝直接GG
            {
                visited[next.x]=1;
                Q.push(next);

            }

        }

    }   
}
int main(int argc, char *argv[])
{
    while(cin>>N>>K)
    {
        memset(visited,0,sizeof(visited));
        BFS();  
        cout<<mina<<endl;
    }   

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值