ZJU 1905


Input

Each test case is a line of input representing s, a string of printable characters.


Output

For each s you should print the largest n such that s = a^n for some string a. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.


Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3







#include<cstdio>
#include<stdlib.h>
#include<string.h>
#include<string>
//#include<map>
#include<cmath>
#include<iostream>
#include <queue>
#include <stack>
#include<algorithm>
#include<set>
using namespace std;
#define INF 1e8
#define inf -0x3f3f3f3f
#define eps 1e-8
#define LL long long
#define maxn 1000010
#define mol 1000000007
int Next[maxn],len;
char s[maxn];
void dd()
{
    int i,k;
	Next[0]=0;Next[1]=0;
	for(i=1;i<len;i++)
	{
	   k=Next[i];
	   while(s[i]!=s[k]&&k)
		   k=Next[k];
	   if(s[i]==s[k])
		   Next[i+1]=k+1;
	   else Next[i+1]=0;
	}
}
int main()
{
	while(~scanf("%s",s)&&s[0]!='.')
	{
		memset(Next,0,sizeof(Next));
       len=strlen(s);
	   dd();
	   printf("%d\n",len/(len-Next[len]));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值