You can Solve a Geometry Problem too

You can Solve a Geometry Problem too

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point.  
 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.  
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output

For each case, print the number of intersections, and one line one case.
 

Sample Input

    
    
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output

    
    
1 3

代码:

#include<stdio.h>
#include<math.h>
#define eps 1e-8
#define min(x,y)   ((x)-(y)<eps?(x):(y))
#define max(x,y)  ((x)-(y)<eps?(y):(x))
typedef struct{
	double x1,y1,x2,y2;
}line;
line L[100];
int Straddle_test(line u,line v) 
{
	double t1=(u.x2-u.x1)*(v.y1-u.y1)-(v.x1-u.x1)*(u.y2-u.y1);
	double t2=(u.x2-u.x1)*(v.y2-u.y1)-(v.x2-u.x1)*(u.y2-u.y1);
	if(t1*t2<eps) return 1; 
	else return 0; 
}
int Quick_rejection(line u,line v)
{
	if(min(u.x1,u.x2)-max(v.x1,v.x2)<eps&&min(u.y1,u.y2)-max(v.y1,v.y2)<eps)
	    return 1;
	else
		return 0;
}
int main()
{
	int n,count,i,j;
	while(scanf("%d",&n)&&n){
		count=0;
		for(i=0;i<n;i++)
			scanf("%lf%lf%lf%lf",&L[i].x1,&L[i].y1,&L[i].x2,&L[i].y2);
		for(i=0;i<n-1;i++)
			for(j=i+1;j<n;j++)
				if(Straddle_test(L[i],L[j])&&Straddle_test(L[j],L[i])
					&&Quick_rejection(L[i],L[j])&&Quick_rejection(L[j],L[i]))
				count++;
		printf("%d\n",count);
	}
    return 0;
}

注:此题是计算几何问题。用到跨立实验和快速排斥实验。还有限于double的计算误差,等于零应表示为fabs()<eps

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值