畅通工程

畅通工程

Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 
Sample Input
  
  
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 
Sample Output
  
  
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.

 

代码:

#include<iostream>
#include<cstring>
#include<utility>
#include<vector>
#include<algorithm>
#include <functional>
#include<list>
#include<iterator>
#include<deque>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<cstdio>
#include<cmath>
#define Maxn 1010
using namespace std;
class string_cmp
{
public:
    bool operator()(const char *str1,const char *str2) const
    {
        return strcmp(str1,str2)<0;
    }
};
int city[Maxn];
int f(int x)
{
    int r=x;
    while(city[r]!=r){
       r=city[r];
    }
    return r;
}
int main()
{
    int n,m,a,b;
    while(scanf("%d",&n),n){
        scanf("%d",&m);
        for(int i=1;i<=n;i++) city[i]=i;
        for(int i=0;i<m;i++){
            scanf("%d%d",&a,&b);
            a=f(a),b=f(b);
            if(a<b)
                city[b]=a;
            else
                city[a]=b;
        }
        int cou=0;
        for(int i=1;i<=n;i++) if(city[i]==i) cou++;
        printf("%d\n",cou-1);
    }
    return 0;
}

 

注:这题是赤裸裸的并查集,属于数据结构范畴,但是也可以用图论的连通分支来做。关于并查集,网上有很多的写法,各有千秋。我见过的有查找是O(1),合并是O(n)的,也有查找是O(n),合并是O(1)的,还有查找是O(logn),合并是O(1)的,还有带路径压缩的查找算法,这种算法会随着每次查找的进行,树的深度减少,目前我觉得难以估计复杂度,但是肯定是远远优于O(logn)的。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值