poj 3261 Milk Patterns

Milk Patterns
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 10175 Accepted: 4587
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers:  N and  K 
Lines 2.. N+1:  N integers, one per line, the quality of the milk on day  i appears on the  ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least  K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

求一个字符串中可重叠的重复次数大于等于k次以上最大重复部分的长度。

这道题目还是二分长度,每组中height个数+1即为满足要求的字符串个数,只要有一组>=k,即符合要求。

还是定理LCP(i,j)=LCP(k-1,k)i+1<=k<=j,这个保证了每组两两字符串有长度为k的公共前缀,并且因为属于同一组,根据传递关系,前缀是一样的。

考虑不同的两组,这两组前缀会一样嘛?答案是不会?因为从两组分别取1个后缀,由于被分成了两组,中间一定横跨了LCP(K1,K2)<k的部分,否则应该被划分成一组.

那么选取的这两个后缀的lcp显然小于k,因此只可能在一组里选择。从中我们一看到了height数组被分组后的强大功能,每个组都表示了一个长度为min(height(i....j))前缀,重复了改组height的个数+1.


此题数据范围较大,不过基数排序仍然可以,使用归并最佳。


代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#define Maxn 20010
using namespace std;

int r[Maxn],sa[Maxn],rank[Maxn],height[Maxn];
int wa[Maxn],wb[Maxn],rs[Maxn],wv[Maxn];

struct cmp_1{
    bool operator()(const int &a,const int &b)const{
        if(r[a]==r[b]) return a<b;
        return r[a]<r[b];
    }
};
struct cmp_2{
    bool operator()(const int &a,const int &b)const{
        if(wv[a]==wv[b]) return a<b;
        return wv[a]<wv[b];
    }
};
int cmp(int *r,int a,int b,int l){
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(int n,int m){
    int i,j,p,*x=wa,*y=wb;
    //for(i=0;i<m;i++) rs[i]=0;
    //for(i=0;i<n;i++) rs[x[i]=r[i]]++;
    //for(i=1;i<m;i++) rs[i]+=rs[i-1];
    //for(i=n-1;i>=0;i--) sa[--rs[x[i]]]=i;
    for(int i=0;i<n;i++) rs[i]=i,x[i]=r[i];
    sort(rs,rs+n,cmp_1());
    for(int i=1;i<n;i++) sa[i]=rs[i];
    for(j=1,p=1;p<n;j<<=1,m=p){
        for(p=0,i=n-j;i<n;i++) y[p++]=i;
        for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
        if(m>20000){
            for(int i=0;i<n;i++) rs[i]=i,wv[i]=x[y[i]];
            sort(rs,rs+n,cmp_2());
            for(int i=1;i<n;i++) sa[i]=y[rs[i]];
        }
        else{
            for(i=0;i<m;i++) rs[i]=0;
            for(i=0;i<n;i++) rs[wv[i]=x[y[i]]]++;
            for(i=1;i<m;i++) rs[i]+=rs[i-1];
            for(i=n-1;i>=0;i--) sa[--rs[wv[i]]]=y[i];
        }
        swap(x,y);
        for(p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
}
void calheight(int n){
    int i,j,k=0;
    for(int i=1;i<n;i++) rank[sa[i]]=i;
    for(int i=1;i<n;height[rank[i++]]=k){
        if(k) k--;
        for(j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
    }
}
bool check(int n,int k,int mid){
    int sum=0;
    for(int i=2;i<n;i++){
        if(height[i]<mid) sum=0;
        else{
            sum++;
            if(sum>=k) return true;
        }
    }
    return false;
}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k)){
        for(int i=1;i<=n;i++)
            scanf("%d",r+i);
        r[0]=r[++n]=0;
        da(n,1000010);
        calheight(n);
        int l=0,r=n;
        while(l<r){
            int mid=l+r+1>>1;
            if(check(n,k-1,mid)) l=mid;
            else r=mid-1;
        }
        printf("%d\n",l);
    }
	return 0;
}

归并比基数排序快了几十毫秒。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值