POJ3261 Milk Patterns

Milk Patterns

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 9881 Accepted: 4436
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ KN) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2.. N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source

USACO 2006 December Gold

题意:求出所给串里最少重复出现k次的子串的长度。
分析:这题也是二分长度求解,只不过每组里判断的是height数组大于长度的次数,然后判断次数是否大于等于k。。。
这题的数字可能很大,所以基数排序需要换成快排,不过数据很弱,我用基数排序也水过去了,附上两份代码。。

基数排序
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=200010;
int r[MAXN],wa[MAXN],wb[MAXN],ws[MAXN],wv[MAXN];
int rank[MAXN],sa[MAXN],height[MAXN];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(int *r,int *sa,int n,int m)
{
    int *x=wa,*y=wb,i,j,p,*t;
    for(i=0;i<m;i++)
        ws[i]=0;
    for(i=0;i<n;i++)
        ws[x[i]=r[i]]++;
    for(i=1;i<m;i++)
        ws[i]+=ws[i-1];
    for(i=n-1;i>=0;i--)
        sa[--ws[x[i]]]=i;
    for(j=1,p=1;p<n;m=p,j*=2)
    {
        for(p=0,i=n-j;i<n;i++)
            y[p++]=i;
        for(i=0;i<n;i++)
            if(sa[i]>=j)
            y[p++]=sa[i]-j;
        for(i=0;i<n;i++)
            wv[i]=x[y[i]];
        for(i=0;i<m;i++)
            ws[i]=0;
        for(i=0;i<n;i++)
            ws[wv[i]]++;
        for(i=1;i<m;i++)
            ws[i]+=ws[i-1];
        for(i=n-1;i>=0;i--)
            sa[--ws[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
    return;
}
void callheight(int *r,int *sa,int n)
{
    int i,j,k=0;
    for(i=1;i<=n;i++)
        rank[sa[i]]=i;
    for(i=0;i<n;height[rank[i++]]=k)
        for(k?k--:0,j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
    return;
}
int k;
bool judge(int len,int n)
{
    int i;
    int num=1;
    for(i=1;i<=n;i++)
    {
        if(height[i]>=len)
            num++;
        else
            num=1;
        if(num>=k)
            return 1;
    }
    return 0;
}
int main()
{
    int n,i;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&r[i]);
        r[n]=0;
        da(r,sa,n+1,100010);
        callheight(r,sa,n);
        int ll=0,rr=n;
        while(ll<rr)
        {
            int mid=(ll+rr+1)>>1;
            if(judge(mid,n))
                ll=mid;
            else
                rr=mid-1;
        }
        printf("%d\n",ll);
    }
    return 0;
}
快排

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=200010;
int wa[MAXN],wb[MAXN],ws[MAXN],wv[MAXN];
int rank[MAXN],sa[MAXN],height[MAXN];
struct Node
{
    int x,id;
    bool operator<(const Node &a)const
    {
        if(x==a.x)
            return id<a.id;
        return x<a.x;
    }
}r[MAXN];
int cmp(int *r,int a,int b,int l)
{
    return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(Node *r,int *sa,int n,int m)
{
    int *x=wa,*y=wb,i,j,p,*t;
    sort(r,r+n);
    for(i=0;i<n;i++)
        sa[i]=r[i].id;
    for(i=1,x[sa[0]]=0;i<n;i++)
        x[sa[i]]=(r[i].x==r[i-1].x)?m-1:m++;
    /*for(i=0;i<m;i++)
        ws[i]=0;
    for(i=0;i<n;i++)
        ws[x[i]=r[i]]++;
    for(i=1;i<m;i++)
        ws[i]+=ws[i-1];
    for(i=n-1;i>=0;i--)
        sa[--ws[x[i]]]=i;*/
    for(j=1,p=1;p<n;m=p,j*=2)
    {
        for(p=0,i=n-j;i<n;i++)
            y[p++]=i;
        for(i=0;i<n;i++)
            if(sa[i]>=j)
            y[p++]=sa[i]-j;
        for(i=0;i<n;i++)
            wv[i]=x[y[i]];
        for(i=0;i<m;i++)
            ws[i]=0;
        for(i=0;i<n;i++)
            ws[wv[i]]++;
        for(i=1;i<m;i++)
            ws[i]+=ws[i-1];
        for(i=n-1;i>=0;i--)
            sa[--ws[wv[i]]]=y[i];
        for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
    }
    return;
}
void callheight(int *r,int *sa,int n)
{
    int i,j,k=0;
    for(i=1;i<=n;i++)
        rank[sa[i]]=i;
    for(i=0;i<n;height[rank[i++]]=k)
        for(k?k--:0,j=sa[rank[i]-1];r[i+k]==r[j+k];k++);
    return;
}
int k;
bool judge(int len,int n)
{
    int i;
    int num=1;
    for(i=1;i<=n;i++)
    {
        if(height[i]>=len)
            num++;
        else
            num=1;
        if(num>=k)
            return 1;
    }
    return 0;
}
int temp[MAXN];
int main()
{
    int n,i;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&temp[i]);
            r[i].x=temp[i];
            r[i].id=i;
        }
        r[n].x=0;
        r[n].id=n;
        da(r,sa,n+1,1);
        callheight(temp,sa,n);
        int ll=0,rr=n;
        while(ll<rr)
        {
            int mid=(ll+rr+1)>>1;
            if(judge(mid,n))
                ll=mid;
            else
                rr=mid-1;
        }
        printf("%d\n",ll);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值