poj1087 floyd+二分图最大匹配

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14191 Accepted: 4773

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

此题的典型的最大流解法,相信一眼就能看出这里不再赘述。传送门:网络流解法 

此题解法不唯一吧,接下来我来介绍floyd+二分图的最大匹配解法

所有插座作为集合X,电器作为集合Y。

如果电器Yi可以插入插座Xi,那么就连一条边<Xi,Yi>

那么如何判断电器Yi能否插入插座Xi呢?当然是Yi的插头是Xi型的,如果Yi的插头不是Xi型的,我们就尝试利用适配器呗,适配器一端是插座,一端是插头,那么适配器在这里起了什么作用呢?

我们可以发现一个适配器(拥有A型插座,B型插头)就相当于能将A型插头变成B型插头,因为A型插头插入适配器的A型插座,不就相当于接着B型插头了吗?

所以说适配器就是插头转换器,又因为适配器个数无限,所有只要存在转换关系,想用多少次都没有关系。而且你会发现插头转换明显可以传递,不就是图的可达性问题吗?用floyed算法即可。

到此为止,算法已经很清晰了。

这题建图是相当麻烦的,并且插头和插座型号最坏400(100+100+100*2)种。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
#define Maxn 410
using namespace std;

int adj[Maxn][Maxn];
int match[Maxn];
int vis[Maxn];
int x,y;
int deep;
bool dfs(int u){
    for(int v=1;v<=y;v++){
        if(adj[u][v]&&vis[v]!=deep){
            vis[v]=deep;
            if(match[v]==-1||dfs(match[v])){
                match[v]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary(){
    memset(match,-1,sizeof match);
    memset(vis,-1,sizeof vis);
    int ans=0;
    for(int i=1;i<=x;i++){
        deep=i;
        if(dfs(i)) ans++;
    }
    return ans;
}
int mat[Maxn][Maxn];
int idy[110];
char sx[Maxn][30],sy[110][30];
char a[30],b[30];
int main()
{
    int k;
    while(~scanf("%d",&x)){
        for(int i=1;i<=x;i++)
            scanf("%s",sx[i]);
        scanf("%d",&y);
        int tot=x;
        for(int i=1;i<=y;i++){
            scanf("%*s%s",sy[i]);
            bool flag=true;
            for(int j=1;j<=tot;j++)
                if(!strcmp(sx[j],sy[i])){
                    idy[i]=j;
                    flag=false;
                    break;
                }
            if(flag){
                strcpy(sx[++tot],sy[i]);
                idy[i]=tot;
            }
        }
        scanf("%d",&k);
        memset(mat,0,sizeof mat);
        for(int i=0;i<k;i++){
            scanf("%s%s",a,b);
            int ida=-1,idb=-1;
            for(int j=1;j<=tot;j++){
                if(!strcmp(a,sx[j])) ida=j;
                if(!strcmp(b,sx[j])) idb=j;
                if(ida!=-1&&idb!=-1) break;
            }
            if(ida==-1){
                strcpy(sx[++tot],a);
                ida=tot;
            }
            if(idb==-1){
                strcpy(sx[++tot],b);
                idb=tot;
            }
            mat[ida][idb]=1;
        }
        for(int i=1;i<=tot;i++)
            mat[i][i]=1;
        for(int k=1;k<=tot;k++)
            for(int i=1;i<=tot;i++)
                for(int j=1;j<=tot;j++)
                    mat[i][j]=mat[i][j]|mat[i][k]&mat[k][j];
        //mat[i][j]=1表示插头i可以变成插头j
        memset(adj,0,sizeof adj); //构造邻接矩阵
        for(int i=1;i<=y;i++){
            for(int j=1;j<=x;j++) //插座编号
                if(mat[idy[i]][j]) adj[j][i]=1; //id可以变成j,即可以插入插座j
        }
        printf("%d\n",y-hungary());
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值