Buy Tickets+POJ+线段树单点更新的灵活运用

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 12927 Accepted: 6410

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243
解决方案:虽知暴力会t,但还是直接线段树暴力,果然无情地t了。看了别人的题解才知,可以从后往前插,因为后面的位置往往是确定的,不用挪。可以这样想,有n个人,最后一个人n要呆在s[n]位子,那么它的位置就固定是s[n],少了最后一个人,又变成了从对n-1个人插队,又从剩下的位置开始数,遇到被占得跳过,数到s[n-1],那么它的位置也就确定了,如此类推,既可以把所有人的排队情况搞出来。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX 2000002
using namespace std;
int sum[4*MMAX];
int ans[MMAX];
int index;
int n;
struct node
{
    int v,s;
} Num[MMAX];
void build(int rt,int L,int R)
{

    if(L==R)
    {
        sum[rt]=1;
    }
    else
    {
        int M=(L+R)/2;
        build(rt*2,L,M);
        build(rt*2+1,M+1,R);
        sum[rt]=sum[rt*2]+sum[rt*2+1];
    }

}
void update(int rt,int L,int R,int S)
{
    sum[rt]--;
    if(L==R)
    {
        index=L;
    }
    else
    {
        int M=(L+R)/2;
        if(S<=sum[rt*2]) update(rt*2,L,M,S);
        else
        {
            S-=sum[rt*2];
            update(rt*2+1,M+1,R,S);
        }

    }

}
int main()
{
    while(~scanf("%d",&n))
    {
        build(1,1,n);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&Num[i].s,&Num[i].v);
        }
        for(int i=n-1; i>=0; i--)
        {
            update(1,1,n,Num[i].s+1) ;
            ans[index]=Num[i].v;
        }
        for(int i=1; i<=n; i++)
        {
            printf("%d%c",ans[i],i==n?'\n':' ');
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值