Babelfish+poj+字典树

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 32392 Accepted: 13929

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops
解决方案:该此题用上字典树效率蛮高的,我用的是孩子兄弟建树法,head指向孩子节点,next指向兄弟节点。w了几次,发现自己定义的最大节点个数少了,最大节点个数应为(单词个数)*(最长单词长度);
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX  1000003
using namespace std;
int head[MMAX];///指向左孩子
int next[MMAX];///指向兄弟节点
char word[MMAX];
int sz;
char ke[MMAX][15];
int val[MMAX];
void Insert(char *w,char *key)
{
    int u=0,v;
    int len=strlen(w);
    for(int i=0; i<len; i++)
    {
        for(v=head[u]; v; v=next[v])
        {
            if(word[v]==w[i]) break;
        }
        if(!v)
        {
            v=sz++;
            next[v]=head[u];
            head[u]=v;
            head[v]=0;
            val[v]=0;
            word[v]=w[i];
        }
        u=v;
    }
    val[v]=1;
    strcpy(ke[v],key);

}
void query(char *Find)
{
    int len=strlen(Find);
    int u=0,v;
    bool flag=true;
    for(int i=0; i<len; i++)
    {
        for(v=head[u]; v; v=next[v])
        {
            if(Find[i]==word[v]) break;
        }
        if(!v)
        {
            flag=false;
            break;
        }
        u=v;
    }
    if(!flag||!val[v])
    {
        printf("eh\n");
    }
    else
    {
        printf("%s\n",ke[v]);
    }

}
int main()
{
    char word[40],kk1[15],kk[15];
    memset(head,0,sizeof(head));
    memset(next,0,sizeof(next));
    memset(val,0,sizeof(val));
    sz=1;
    while(gets(word)&&word[0]!='\0')
    {
        sscanf(word,"%s %s",kk1,kk);
        Insert(kk,kk1);

    }
    while(gets(kk)&&kk[0]!='\0')
    {
        query(kk);

    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值