Count Color+POJ+线段树区间更新+位运算(lazy标志的运用)

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35352 Accepted: 10654

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1
解决方案:由于只有30种颜色,所以可以用一个32位的无符号整形来标志颜色,在往上更新的时候:左右儿子区间或操作结果更新到父节点。查询时先标记出现过的颜色,最后再统计。本题主要是lazy标记的运用,其他都没什么。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX  100005
#define lson rt<<1,L,M
#define rson rt<<1|1,M+1,R
using namespace std;
unsigned int color[MMAX<<2];///记录区间的颜色
bool lazy[MMAX<<2];///lazy标志
bool vis[33];
int N,T,Q;
void get(unsigned t)
{
    for(int i=0; i<T; i++)
    {
        if((t>>i)&0x00000001)
        {
            vis[i]=true;
        }
    }
}
void build(int rt,int L,int R)
{
    if(L==R)
    {
        color[rt]=0x00000001;
        lazy[rt]=false;
    }
    else
    {
        int M=(L+R)>>1;
        build(lson);
        build(rson);
        color[rt]=0x00000001;
        lazy[rt]=false;
    }
}
void push_up(int rt)
{
    color[rt]=(color[rt<<1]|color[rt<<1|1]);
}
void push_down(int rt)
{
   if(lazy[rt]){
   lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];
   color[rt<<1]=color[rt<<1|1]=color[rt];
   lazy[rt]=false;
   }
}
void update(int rt,int L,int R,int c,int sl,int sr)
{

    if(sl<=L&&sr>=R)
    {
        color[rt]=0x00000001<<(c-1);
        lazy[rt]=true;
    }
    else
    {
        int M=(L+R)>>1;
        push_down(rt);
        if(sl<=M) update(lson,c,sl,sr);
        if(sr>M) update(rson,c,sl,sr);
        push_up(rt);
    }

}
void query(int rt,int L,int R,int ql,int qr)
{
    if(ql<=L&&qr>=R)
    {
        get(color[rt]);
    }
    else
    {
        int M=(L+R)>>1;
        push_down(rt);
        if(ql<=M)query(lson,ql,qr);
        if(qr>M) query(rson,ql,qr);
    }

}
int main()
{
    while(~scanf("%d%d%d",&N,&T,&Q))
    {
        build(1,1,N);
        for(int i=0; i<Q; i++)
        {
            int a,b,c;
            char op;
            scanf("\n%c",&op);
            if(op=='C')
            {
                scanf("%d%d%d",&a,&b,&c);
                 if(a>b) {int temp=a;a=b;b=temp;}
                update(1,1,N,c,a,b);
            }
            else
            {
                scanf("%d%d",&a,&b);
                if(a>b) {int temp=a;a=b;b=temp;}
                memset(vis,false,sizeof(vis));
                query(1,1,N,a,b);
                int cnt=0;
                for(int i=0; i<T; i++)
                {
                    cnt+=vis[i];
                }
                printf("%d\n",cnt);
            }

        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值