Party All the Time+hdu+三分搜索

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3501    Accepted Submission(s): 1115


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
  
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
  
  
Case #1: 832
解决方案:枚举best place,在某区间,随best place从小到大,总的spirit有一个从变小再变大的过程,所以三分搜索。
code:
#include<iostream>
#include<cstdio>
#include<cmath>
#define MMAX 50005
using namespace std;
struct node
{
    double x,s;
} spirit[MMAX];
int N;
double cal(double mid)
{
    double sum=0.0;
    for(int i=0; i<N; i++)
    {
        sum+=fabs((spirit[i].x-mid)*(spirit[i].x-mid)*(spirit[i].x-mid))*spirit[i].s;
    }
    return sum;
}
int main()
{
    int t,k=0;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&N);
        double left=10e7,right=0.0,mid,midmid;
        for(int i=0;i<N;i++){
            scanf("%lf%lf",&spirit[i].x,&spirit[i].s);
            left=min(spirit[i].x,left);
            right=max(spirit[i].x,right);
        }
        double midv,midmidv;
        while(right-left>0.0000001){
            mid=(left+right)/2.0;
            midmid=(mid+right)/2.0;
            midv=cal(mid);
            midmidv=cal(midmid);
            if(midv<=midmidv) right=midmid;
            else left=mid;
        }
        printf("Case #%d: %.0lf\n",++k,cal(left));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值