Party at Hali-Bula+hdu+经典树形dp

4 篇文章 0 订阅

Party at Hali-Bula

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1890    Accepted Submission(s): 657


Problem Description
Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.
 

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.
 

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.
 

Sample Input
  
  
6 Jason Jack Jason Joe Jack Jill Jason John Jack Jim Jill 2 Ming Cho Ming 0
 

Sample Output
  
  
4 Yes 1 No
解决方案:经典树形dp,dp[i][0]表示i节点不选,可选的人数,则dp[i][0]= ∑max(dp[j][1],dp[j][0]),dp[i][1]表示i节点选,
dp[i][1]=1+dp[i][0];判断是否唯一:加一个数组dup[i][1],dup[i][0],1表示唯一,0表示不唯一。则对于叶子节点:dp[i][1]=dp[i][0]=1;
若dp[v][0]>dp[v][1]&&dup[v][0]==0 或dp[v][0]<dp[v][1]&&dup[v][1]==0或dp[v][0]==dp[v][1],则dup[u][0]=0
若dup[v][0]==0则dup[u][1]=0;
code:
#include <iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
const int maxn=210;
int ehead[maxn];
int dp[210][2],dup[210][2];
int k,n;
struct edge
{
    int to,next;
} E[maxn*2];
void add(int from,int to)
{
    E[k].to=to;
    E[k].next=ehead[from];
    ehead[from]=k++;
}
void init()
{
    memset(ehead,-1,sizeof(ehead));
    memset(dp,0,sizeof(dp));
    memset(dup,-1,sizeof(dup));
    k=0;
    for(int i=1; i<=n; i++)
    {
        dp[i][0]=0,dp[i][1]=1;
        dup[i][1]=dup[i][0]=1;
    }
}
void dfs(int u)
{

    if(ehead[u]==-1)
    {
        dp[u][0]=0,dp[u][1]=1;
        dup[u][0]=dup[u][1]=1;
    }
    else
    {

        for(int i=ehead[u]; i!=-1; i=E[i].next)
        {
            int v=E[i].to;
            dfs(v);
            dp[u][0]+=max(dp[v][0],dp[v][1]);
            dp[u][1]+=dp[v][0];
            if(dp[v][0]>dp[v][1]&&dup[v][0]==0) dup[u][0]=0;
            else if(dp[v][0]<dp[v][1]&&dup[v][1]==0) dup[u][0]=0;
            else if(dp[v][0]==dp[v][1]) dup[u][0]=0;
            else ;
            if(dup[v][0]==0) dup[u][1]=0;
        }
    }


}
int main()
{
    string name1,name2;
    while(~scanf("%d",&n)&&n)
    {
        init();
        map<string ,int>M;
        int No=1;
        cin>>name1;
        M[name1]=No++;
        for(int i=0; i<n-1; i++)
        {
            cin>>name1>>name2;
            if(!M[name1])
            {
                M[name1]=No++;
            }
            if(!M[name2])
            {
                M[name2]=No++;
            }
            add(M[name2],M[name1]);
        }
        dfs(1);
        if(dp[1][0]>dp[1][1])
        {
            printf("%d ",dp[1][0]);
            if(dup[1][0]==0)
            {
                printf("No\n");
            }
            else printf("Yes\n");
        }
        else if(dp[1][0]<dp[1][1])
        {
            printf("%d ",dp[1][1]);
            if(dup[1][1]==0)
            {
                printf("No\n");
            }
            else printf("Yes\n");
        }
        else
        {
            printf("%d ",dp[1][1]);
            printf("No\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值