hdu 1003 (Max Sum) hdu 1231(最大连续子序列)

dp  Max Sum   最大连续子序列   两道题基本一样

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 217225    Accepted Submission(s): 51238


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 
题意:给出一个序列,找出和最大的连续子序列,并输出子序列的首尾。

题解:dp[i]=max(dp[i-1]+dp[i],dp[i]);每次有两种情况,dp[i]作为上一个子序列的终点前一个数,或者作为一个新序列的起点。

#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
	int t,n,max,e,s,res,i;
	int cas=1;
	int a[100100],d[100100];
	scanf ("%d",&t);
	while (t--){
		scanf ("%d",&n);
		for (i=1;i<=n;i++){
			scanf ("%d",&a[i]);
		}
		d[1]=a[1];
		for (i=2;i<=n;i++){
			if (d[i-1]<0) d[i]=a[i];
			else
			d[i]=d[i-1]+a[i];
		}
		max=d[1];e=1;
		for (i=2;i<=n;i++){
			if (max<d[i]){
				max=d[i];
				e=i;//记录子序列的终点
			}
		}
		res=0;s=e;
		for (i=e;i>=1;i--){
			res+=a[i];
			if (res==max) s=i;//记录子序列的起点
		}
		printf ("Case %d:\n%d %d %d\n",cas++,max,s,e);
		if (t!=0)
		printf ("\n");
	}
	return 0;
	
}

最大连续子序列

#include<cstdio>
#include<algorithm>
using namespace std;

int main(){
	int k,i,j,e,f,res,s;
	int n,m;
	int flag;
	int a[10100],d[10100];
	while (scanf ("%d",&k)!=EOF){
		if (k==0) break;
		int s=0;
		flag=0;
		for (i=1;i<=k;i++){
			scanf ("%d",&a[i]);
			if (a[i]>=0) flag=1;
		}
		if (!flag){
			printf ("0 %d %d\n",a[1],a[k]);
			continue;
		}
		d[1]=a[1];
		for (i=2;i<=k;i++){
			if (d[i-1]<0) d[i]=a[i];
			else
			d[i]=d[i-1]+a[i];
		}
		s=d[1];e=a[1];j=1;
		for (i=2;i<=k;i++){
			if (s<d[i]){
				s=d[i];
				e=a[i];
				j=i;
			}
		}
		f=a[j];res=0;
		for (i=j;i>=1;i--){
			res+=a[i];
			if (res==s)
			f=a[i];
		}	
		
		printf ("%d %d %d\n",s,f,e);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值